Closed Bug 1363152 Opened 3 years ago Closed 3 years ago

[e10s] text color of <option> not shown

Categories

(Core :: Layout: Form Controls, defect, P2)

53 Branch
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: j.lammerts, Unassigned, NeedInfo)

References

(Blocks 1 open bug)

Details

(Keywords: regression, testcase, Whiteboard: DUPEME)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170504105526

Steps to reproduce:

Create html:
<select id="sel">
  <option class="a" value="1">Bla1</option>
  <option class="b" value="2">Bla2</option>
</select>

Create CSS:
.a {color: red;}
.b {color: green;}


Actual results:

Options are shown in standard (black) color


Expected results:

Option 1 should be in red, option 2 should be in green.

This does work on 53.0.2 32 bit, but does not work on 53.0.2 64 bit. Confirmed by other testers.
Component: Untriaged → Layout: Form Controls
Keywords: 64bit
Product: Firefox → Core
It works in 64-bit builds with e10s disabled, so I suspect this is a dupe
of some e10s-select bug.

I'm assuming e10s is auto-disabled in 32-bit builds so that's the reason
it works there.
Blocks: e10s-select
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: 64bitregression, testcase
OS: Unspecified → All
Hardware: Unspecified → All
Summary: text color of option not show in 64bit, but is shown in 32 bit version of 53.0.2 → [e10s] text color of <option> not shown
Whiteboard: DUPEME
See Also: → 1350258
Priority: -- → P2
I tested on 57.0a1 (2017-09-13) (64-bit), and it works now. Does it still happen on your machine?
Flags: needinfo?(j.lammerts)
It seems to work now.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
"work now" doesn't mean INVALID. WFM is a better fit for this.
Resolution: INVALID → WORKSFORME
You need to log in before you can comment on or make changes to this bug.