Location bar suggests autofill for prefix matches of hosts that are also keywords, but then uses the keyword instead of autofill

RESOLVED DUPLICATE of bug 1124238

Status

()

RESOLVED DUPLICATE of bug 1124238
2 years ago
2 years ago

People

(Reporter: Gijs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
STR:

1. clean profile
2. create a keyword bookmark for bugzilla's search with the keyword 'bug'
3. type 'bug' in the location bar, observe autofill, hit enter

ER:
one of:
- don't autofill bugzilla.mozilla.org until there's no more keyword match
- when autofilling, and then hitting enter, actually navigate to the autofilled bugzilla.mozilla.org domain

AR:
we autofill bugzilla.mozilla.org, but when you hit enter we load the query.cgi page with no input.
sounds like dupe of bug 1124238?
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1124238
You need to log in before you can comment on or make changes to this bug.