Closed Bug 1363275 Opened 4 years ago Closed 4 years ago

firefox update dialog box on windows 10 has blurred text

Categories

(Toolkit :: Application Update, defect)

53 Branch
Unspecified
Windows 10
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: stephenranjit, Assigned: mhowell)

References

Details

Attachments

(4 files)

Attached image firefox_blurred.png
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170504105526

Steps to reproduce:

launched firefox.


Actual results:

firefox update started up. the window title "Firefox Update" is clear and readable but the text below it is blurred.
"Firefox is installing your updates and will start in a few moments..."
I thought it was a problem with either my glasses or my display.


Expected results:

the update dialog box should contain clear text throughout
Component: Untriaged → Application Update
OS: Unspecified → Windows 10
Product: Firefox → Toolkit
Reporter, is there anything unusual about your system that you can think of that may contribute to this?
Flags: needinfo?(stephenranjit)
I think both of these screenshots are showing improper DPI scaling. Maybe the different looking end results are caused by the behavior changing in the Windows 10 Creators' Update, but I think they would both be fixed if we updated our manifest.
Attached image DPI-aware screenshot
With the above patch, the dialog now looks like this on my Windows 10.0.15063 system at 200%. Previously it looked like rstrong's screenshot.
Assignee: nobody → mhowell
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Comment on attachment 8865953 [details]
Bug 1363275 - Make the updater progress dialog DPI-aware on Windows.

https://reviewboard.mozilla.org/r/137544/#review140696

Thanks!
Attachment #8865953 - Flags: review?(robert.strong.bugs) → review+
Pushed by mhowell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6eeb4b1809da
Make the updater progress dialog DPI-aware on Windows. r=rstrong
https://hg.mozilla.org/mozilla-central/rev/6eeb4b1809da
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Duplicate of this bug: 1371241
Flags: needinfo?(stephenranjit)
You need to log in before you can comment on or make changes to this bug.