Opening web link triggers 100% CPU usage in kmozillahelper (KDE component)

REOPENED
Unassigned

Status

REOPENED
a year ago
a month ago

People

(Reporter: vkrevs, Unassigned)

Tracking

({perf})

52 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.96 Safari/537.36

Steps to reproduce:

openSUSE 42.2, Thunderbird 52.1.0 from http://download.opensuse.org/repositories/mozilla/openSUSE_Leap_42.2/x86_64/.

Click on a new unread HTML email with web links.



Actual results:

Thunderbird seems to spawn a new instance of kmozillahelper and kmozillahelper spends up to a minute enumerating plugins in /usr/lib64/qt5/plugins/kf5/ and services in /usr/share/kservices5/ fully utilizing one CPU core.

This happens for each new unread HTML email.

I have reported this here in openSUSE bugzilla https://bugzilla.suse.com/show_bug.cgi?id=1037806

and the opensuse developers seem to think it is a Thunderbird bug (see comment #4 in the opensuse bug report).


Expected results:

Thunderbird/Kmozillahelper should not trigger high CPU consumption for each HTML email with web links.

Comment 1

a year ago
Hmm, why is this a Thunderbird bug? kmozillahelper is a component of KDE, so why don't you complain to them?
Surely, digging around in KDE plugins (qt5/plugins) has nothing to do with Mozilla software.

Should I be mistaken, please re-open the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID

Updated

a year ago
Summary: TB bug triggers 100% CPU usage in kmozillahelper → TB bug triggers 100% CPU usage in kmozillahelper (KDE component)
According to https://bugzilla.suse.com/show_bug.cgi?id=1037806 the reason why this is a problem is that:
"The issue is that it calls nsMIMEInfoUnix::GetHasDefaultHandler way to often with totally nonsensical parameters, like "subsystem", "c", "C", "Zc"."

This looks like there are really non-useful calls to GetHasDefaultHandler which also is expensive with Gtk but not as visible as it is in the case of the external integration with KDE.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INVALID → ---

Updated

a year ago
Component: Untriaged → General
Keywords: perf

Comment 3

9 months ago
Is this also a problem prior to version 52.1.0, i.e. is this a regression??


(In reply to Wolfgang Rosenauer [:wolfiR] from comment #2)
> ...
> This looks like there are really non-useful calls to GetHasDefaultHandler
> which also is expensive with Gtk but not as visible as it is in the case of
> the external integration with KDE.

https://bugzilla.suse.com/show_bug.cgi?id=1037806#c4
"I see a ton of senseless queries for HANDLEREXISTS, so it's a bug in thunderbird."
Flags: needinfo?(vkrevs)
Summary: TB bug triggers 100% CPU usage in kmozillahelper (KDE component) → Opening web link triggers 100% CPU usage in kmozillahelper (KDE component)
(Reporter)

Comment 4

9 months ago
This wasn't the case with earlier TB versions.
Flags: needinfo?(vkrevs)

Comment 5

a month ago
Does this issue still exist in 52.9.1  or v60.0 of Thunderbird? 
(Unable to reproduce here but possibly different desktop configuration than OP)


As far as I can tell - The component mentioned is in toolkit, not Thunderbird: https://dxr.mozilla.org/comm-central/search?q=nsMIMEInfoUnix&redirect=false
(Reporter)

Comment 6

a month ago
I've upgraded to openSUSE Leap 15.0 earlier this year, which includes both v52.9.1 and v60, and neither appear to trigger this  problem anymore.
You need to log in before you can comment on or make changes to this bug.