Remove customizeToolbar.dtd dependency from browser-doctype

RESOLVED DUPLICATE of bug 1428938

Status

()

RESOLVED DUPLICATE of bug 1428938
2 years ago
11 months ago

People

(Reporter: Gijs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
We seem to still be sourcing this but I'm fairly sure we don't use any of the strings anymore, because we got rid of the old customize implementations... Florian? I guess we don't have tests to check for unused strings / dtd files?
Flags: needinfo?(florian)
The dtd file is used from toolkit/content/customizeToolbar.xul so it's not unreferenced as far as browser_all_files_referenced.js is concerned.

For a test to check for unused strings inside dtd files, see bug 1320594 where I had a work in progress.
Flags: needinfo?(florian)
(Reporter)

Comment 2

2 years ago
(In reply to Florian Quèze [:florian] [:flo] from comment #1)
> The dtd file is used from toolkit/content/customizeToolbar.xul so it's not
> unreferenced as far as browser_all_files_referenced.js is concerned.

customizeToolbar.xul, which is used from... where, in m-c? :-(
Flags: needinfo?(florian)
(In reply to :Gijs from comment #2)
> (In reply to Florian Quèze [:florian] [:flo] from comment #1)
> > The dtd file is used from toolkit/content/customizeToolbar.xul so it's not
> > unreferenced as far as browser_all_files_referenced.js is concerned.
> 
> customizeToolbar.xul, which is used from... where, in m-c? :-(

Whitelisted at http://searchfox.org/mozilla-central/rev/224cc663d54085994a4871ef464b7662e0721e83/browser/base/content/test/static/browser_all_files_referenced.js#139 (unfortunately I pasted the wrong bug number on that line :-(. The actual bug to remove that whitelist entry is bug 1343833).
Flags: needinfo?(florian)
(Reporter)

Updated

2 years ago
Depends on: 1343833
(Reporter)

Comment 4

11 months ago
Fixed in bug 1428938.
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1428938
You need to log in before you can comment on or make changes to this bug.