2.69% tsvgr_opacity (osx-10-10) regression on push bcffb170c5718c54d7a18842a082437831b20de5 (Tue May 9 2017)

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
8 months ago
8 months ago

People

(Reporter: igoldan, Unassigned)

Tracking

(Blocks: 1 bug, {perf, regression, talos-regression})

Firefox Tracking Flags

(Not tracked)

Details

Talos has detected a Firefox performance regression from push bcffb170c5718c54d7a18842a082437831b20de5. As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

  3%  tsvgr_opacity summary osx-10-10 opt      419.92 -> 431.23


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=6473

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Buildbot/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Buildbot/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
I see two relevant changesets for this patch. Could you take a look and confirm this regression?
Flags: needinfo?(nfroyd)
Flags: needinfo?(cpeterson)
The autoland code from Servo isn't even compiled, so it can't be that.  I'm very skeptical that building files in unified mode would have resulted in a regression, too.
Flags: needinfo?(nfroyd)
Flags: needinfo?(cpeterson)
There is a 2 hour gap, during which the regression appeared. I will look over changesets uploaded in that interval.
Thank you, :froydnj, for the quick notice.
this looks like bug 1363102 instead:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=6c9c06059b386f7c879a4926c051783472ec7ce4&tochange=5bcdf4e6459b6c7207924dc666075769839705aa

here is the graph:
https://treeherder.mozilla.org/perf.html#/graphs?series=%5Bmozilla-inbound,cf66eebbefd68c20ae85ba4218e71aa6746fb863,1,1%5D&zoom=1494232528059.8706,1494292510100.3237,398.12734368142117,445.8801526701852


I see that a bit later the data comes back down, it seems to be noisier.  Possibly this is some random noise in the system, not a real regression, lets see if :baku has any ideas before writing this off.

:baku, do you see anything in your patch that could cause a svg talos regression?
Blocks: 1363102
Flags: needinfo?(amarchesini)
It seems noise, that patch adds an error check in Location::ToString(). Nothing related with SVG.
Flags: needinfo?(amarchesini)
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.