Closed Bug 1363406 Opened 4 years ago Closed 4 years ago

Regression: "Show your bookmarks" button shrinks in size if moved to the Bookmarks Toolbar

Categories

(Firefox :: Theme, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 55
Iteration:
55.5 - May 15
Tracking Status
firefox-esr52 --- unaffected
firefox53 --- unaffected
firefox54 --- unaffected
firefox55 --- verified

People

(Reporter: itiel_yn8, Assigned: johannh)

References

Details

(Keywords: regression, Whiteboard: [photon-visual][p1])

Attachments

(2 files)

Attached image Shrinking button
Tested environment:
Windows 10 build 1607

STR:
1. Install latest Nightly
2. Enable the Bookmarks Toolbar
3. Move the "Show your bookmarks" button to the Bookmarks Toolbar

AR:
The "Show your bookmarks" button shrinks in size (the "Bookmark this page" button remains unchanged). See attached.

ER:
It shouldn't.

This bug doesn't seem to affect any other built-in Firefox buttons.

Regression range:
Good: 2.5.17
Bad: 3.5.17

Mozregression narrows it down to:
2017-05-09T17:48:09: DEBUG : Using url: https://hg.mozilla.org/mozilla-central/json-pushes?changeset=a748acbebbde373a88868dc02910fb2bc5e6a023&full=1
2017-05-09T17:48:10: DEBUG : Found commit message:
Backed out changeset d3197ffef609 (bug 1338217) for failures in test_webassembly_compile.html on at least Windows VM debug a=backout a=merge
Maybe a dupe? Dao was following a similar regression recently.
Component: Bookmarks & History → Theme
Flags: needinfo?(dao+bmo)
(In reply to ItielMaN from comment #0)
> Mozregression narrows it down to:
> 2017-05-09T17:48:09: DEBUG : Using url:
> https://hg.mozilla.org/mozilla-central/json-pushes?changeset=a748acbebbde373a88868dc02910fb2bc5e6a023&full=1

Likely a regression from bug 1352364.
Blocks: 1352364
Flags: needinfo?(dao+bmo) → needinfo?(jhofmann)
Whiteboard: [photon-visual][p1]
Flags: qe-verify?
Priority: -- → P2
Yup, sorry, my fault. Taking.
Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
Flags: needinfo?(jhofmann)
Comment on attachment 8866028 [details]
Bug 1363406 - Only apply padding to the bookmark menu button in the nav bar.

https://reviewboard.mozilla.org/r/137620/#review140736
Attachment #8866028 - Flags: review?(dao+bmo) → review+
Duplicate of this bug: 1363476
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b818cfd054a6
Only apply padding to the bookmark menu button in the nav bar. r=dao
Iteration: --- → 55.5 - May 15
Priority: P2 → P1
https://hg.mozilla.org/mozilla-central/rev/b818cfd054a6
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Confirmed fixed on latest Nightly.
Marking as VERIFIED FIXED.
Status: RESOLVED → VERIFIED
Flags: qe-verify?
I tested this issue using FF Nightly 56.0a1(2017-06-13) and I can confirm the fix.
You need to log in before you can comment on or make changes to this bug.