Crash in mozalloc_abort | NS_DebugBreak | mozilla::ipc::FatalError | mozilla::net::PNeckoChild::SendPWyciwygChannelConstructor

RESOLVED FIXED in Firefox 54

Status

()

defect
--
critical
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: marcia, Assigned: junior)

Tracking

({crash})

55 Branch
mozilla55
Unspecified
Windows 10
Points:
---
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox53 unaffected, firefox54 fixed, firefox55 fixed)

Details

(Whiteboard: [necko-active], crash signature)

Attachments

(1 attachment)

This bug was filed from the Socorro interface and is 
report bp-8ded83b9-3bdf-43cc-bcae-665710170509.
=============================================================

Seen while looking at crash stats - not sure where to bucket this one - crashes started using 20170508030204 and also occur in small volume on 54 branch.

Possible regression range based on Build ID: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=37a5b7f6f101df2eb292b1b6baaf1540c9920e20&tochange=1fda52a1f3b81cf1a821155998dca637bb64e3d9
@junior, is this the same root cause as bug 1359951?
Flags: needinfo?(juhsu)
(Assignee)

Comment 2

2 years ago
(In reply to Shih-Chiang Chien [:schien] (UTC+8) (use ni? plz) from comment #1)
> @junior, is this the same root cause as bug 1359951?

Yes
Assignee: nobody → juhsu
Flags: needinfo?(juhsu)
(Assignee)

Comment 3

2 years ago
Similar solution with Bug 1359951
Attachment #8866235 - Flags: review?(valentin.gosu)
(Assignee)

Updated

2 years ago
Whiteboard: [necko-active]
Attachment #8866235 - Flags: review?(valentin.gosu) → review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Comment 5

2 years ago
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7cd208304d1f
Ensure not sending wyciwyg constructor when shutting down, r=valentin
Keywords: checkin-needed
This may have caused failures like https://treeherder.mozilla.org/logviewer.html#?job_id=98065165&repo=mozilla-inbound to start happening frequently on Windows

Backed out in https://hg.mozilla.org/integration/mozilla-inbound/rev/66b20d029e95
Flags: needinfo?(juhsu)
These failures were actually from bug 469228.
Keywords: checkin-needed
(Assignee)

Comment 8

2 years ago
cancel the ni by last comment
Flags: needinfo?(juhsu)

Comment 9

2 years ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0770cc3b037f
Ensure that the wyciwyg constructor isn't sent when shutting down. r=valentin
Keywords: checkin-needed

Comment 10

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/0770cc3b037f
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
(Assignee)

Updated

2 years ago
Blocks: 1363659
Valentin, can you please request Beta approval on this since Junior is OOO? Thanks!
Flags: needinfo?(valentin.gosu)
Comment on attachment 8866235 [details] [diff] [review]
wyciwyg_crash - v1

Approval Request Comment
[Feature/Bug causing the regression]: unknown.
[User impact if declined]: Possible race condition leading to child process crash.
[Is this code covered by automated tests?]: Yes, this case should be covered by wyciwyg tests.
[Has the fix been verified in Nightly?]: Just landed.
[Needs manual test from QE? If yes, steps to reproduce]: No.
[List of other uplifts needed for the feature/fix]: None.
[Is the change risky?]: No.
[Why is the change risky/not risky?]: This just adds simple check, similar to other fixes for similar bugs.
[String changes made/needed]: none.
Flags: needinfo?(valentin.gosu)
Attachment #8866235 - Flags: approval-mozilla-beta?
Attachment #8866235 - Flags: approval-mozilla-aurora?
Comment on attachment 8866235 [details] [diff] [review]
wyciwyg_crash - v1

Fix a crash. Beta54+. Should be in 54 beta 8.
Attachment #8866235 - Flags: approval-mozilla-beta?
Attachment #8866235 - Flags: approval-mozilla-beta+
Attachment #8866235 - Flags: approval-mozilla-aurora?
Attachment #8866235 - Flags: approval-mozilla-aurora-
(In reply to Valentin Gosu [:valentin] from comment #12)
> [Is this code covered by automated tests?]: Yes, this case should be covered
> by wyciwyg tests.
> [Has the fix been verified in Nightly?]: Just landed.
> [Needs manual test from QE? If yes, steps to reproduce]: No.

Setting qe-verify- based on Valentin's assessment on manual testing needs and the fact that this fix has automated coverage.
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.