Spike in CPU Usage on Win10 on latest Nightly

RESOLVED DUPLICATE of bug 1363176

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 1363176
a year ago
a year ago

People

(Reporter: ritu, Unassigned)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
BuildId: 20170508030204

STR:
1. Launch Nightly firefox (new or existing profile)
2. I would open the following tabs: gmail, amazon, facebook, linked, cnn, youtube, google.com 
3. login to gmail,Fb,LI, 
4. click around tabs for a bit (5 seconds). 
5. I would then watch for tab throbbers spinning (re: bug 1363440) and CPU usage

CPU Usage would stay @30% even if I was not using my Nightly actively.
(Reporter)

Comment 1

a year ago
I ran mozregression-script.py --bad 2017-05-09 --good 2017-05-01

32:38.82 INFO: Narrowed inbound regression window from [82c2d17e, 96605941] (3 revisions) to [d7e40bb8, 96605941] (2 revisions) (~1 steps left)
32:38.82 INFO: Oh noes, no (more) inbound revisions :(
32:38.82 INFO: Last good revision: d7e40bb852ea047a0e5f530bcdc04d29a1765001
32:38.82 INFO: First bad revision: 96605941c0021795376d9c6ec1e458de2fac329e
32:38.82 INFO: Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d7e40bb852ea047a0e5f530bcdc04d29a1765001&tochange=96605941c0021795376d9c6ec1e458de2fac329e

On the good builds, CPU usage would go down from 60-80% to 5-6%. CPU usage would stay at ~30-40% on the bad builds.
Summary: Spike in CPU Usage on latest Nightly → Spike in CPU Usage on Win10 on latest Nightly
(Reporter)

Updated

a year ago
status-firefox55: --- → affected
(Reporter)

Comment 2

a year ago
[Tracking Requested - why for this release]:

If this was widespread enough, I'd consider this a blocker for 55 merge to Beta.
tracking-firefox55: --- → ?
For this particular bug, the Gecko Profiler Add-on might help illuminate what's eating cycles (assuming that the thread in question is one of the ones being profiled).

You can install the profiler add-on here:

http://perf-html.io/

Then, in order to capture as many thread samples as possible, in the panel attached to the button the profiler adds to your toolbar, in Threads, just put a ,

Yep, a comma.

Then click Apply, wait a few seconds with your 30% spinning Nightly, and then open the panel and choose Capture Profile.

Then follow the instructions at the bottom of https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Reporting_a_Performance_Problem to share the profile and post the link here, and I'll take a look if you needinfo me.
Possibly a dupe of bug 1363176?  Bug 1354641 is in the range from comment 1.
Tracking 55+ as we investigate this cpu usage issue.
tracking-firefox55: ? → +
ni on Ritu to provide what mconley requests in Comment 3.
Flags: needinfo?(rkothari)
Bug 1363176 was called out in today's channel meeting in relation to a Facebook issue - might this be a dupe of that bug (also mentioned in Comment 4).
(Reporter)

Comment 8

a year ago
I am using Nightly buildid: 20170510030301. With that build, if I have a FB tab open, the CPU usage goes up significantly, hovering at ~40%. Does that 5-10 build have the fix backed out in it?
Flags: needinfo?(rkothari)
(Reporter)

Comment 9

a year ago
https://perfht.ml/2pCJ4R7 - Mike here goes.
Flags: needinfo?(mconley)
(In reply to Ritu Kothari (:ritu) from comment #9)
> https://perfht.ml/2pCJ4R7 - Mike here goes.

I see a lot of time being spent attempting to spellcheck... is this from today's Nightly? Bug 1354641 recently landed which may have contributed to this, but got backed out. The back out should be effective as of today's Nightly.
Flags: needinfo?(mconley) → needinfo?(rkothari)
(Reporter)

Comment 11

a year ago
The build id is 20170510030301, I don't believe it has the spellchecker backout. Based on comment 10, this is a confirmed dup of  bug 1363176.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(rkothari)
Resolution: --- → DUPLICATE
Duplicate of bug: 1363176
Updating the status flag so it is reflected properly on the release health dashboard. The duplicate bug is fixed, and we don't need to track this duplicate for 55.
status-firefox55: affected → ---
tracking-firefox55: + → ---
You need to log in before you can comment on or make changes to this bug.