Missing automated Url-html correction on Links

RESOLVED INVALID

Status

Invalid Bugs
General
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: Thomas Kaltenstadler, Unassigned)

Tracking

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170504112025

Steps to reproduce:

A) search with google anything
B) At a resulting link copy the link by use of  right mouse button
(https://www.google.de/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&cad=rja&uact=8&ved=0ahUKEwiCz6bQuOTTAhWIJ1AKHVjYDaoQFggmMAA&url=https%3A%2F%2Fwww.test.de%2F&usg=AFQjCNE6ZMWYHbspL38_McKbUiTMwHL-0A)
cut the destination part after "..url=" of the link like 
https%3A%2F%2Fwww.test.de%2F&usg=AFQjCNE6ZMWYHbspL38_McKbUiTMwHL-0A



Actual results:

Firefox is not  able to recognise that html style text was entered to  url bar manually
so link is not  opened correctly
I'm using Windows computer


Expected results:

translate
https%3A%2F%2Fwww.test.de%2F&usg=AFQjCNE6ZMWYHbspL38_McKbUiTMwHL-0A
to 
https://www.test.de/&usg=AFQjCNE6ZMWYHbspL38_McKbUiTMwHL-0A
Its pretty easy to fix but nerving since 20 years 
BTW Why becomes firefox  so slow if a lot of  Windows are open, Isn't the any internal backgrond window process management? This could save a lot of CO2 in our world!
Kindest regards Thomas from Datapower Germany
It's not a browser bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Component: Untriaged → General
Product: Firefox → Invalid Bugs
Resolution: --- → INVALID
Version: 52 Branch → unspecified
You can use this extension to automatically decode Google search result URLs:
https://addons.mozilla.org/firefox/addon/google-search-link-fix/
You need to log in before you can comment on or make changes to this bug.