makeC++SharedLib_r called with bad args

VERIFIED INVALID

Status

SeaMonkey
Build Config
VERIFIED INVALID
16 years ago
13 years ago

People

(Reporter: David Favor, Assigned: hacker formerly known as seawood@netscape.com)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
On AIX 433 using the final version of xlc 3.6.6.7 the file autoconf.mk sets
MOZ_GTK_LDFLAGS to contain "-Wl,-brtl". The option "-Wl" is invalid for this
version of the compiler, so each time this option is passed to makeC++SharedLib_r
a link error occurs.
MOZ_GTK_LDFLAGS is set by the output of `gtk-config --libs`.  It looks like
you're using a version of gtk+ that was compiled by gcc perhaps?

Comment 2

16 years ago
If you are using xlc to compile Mozilla and are using the GTK+ version from the
AIX Linux Toolbox, then you need to make the following change to gtk-config
(found  in /opt/freeware/bin/gtk-config):

Change the line:
echo $libdirs -Wl,-brtl -lgtk -lgdk $my_glib_libs -lintl -lXext -lX11 -lm
to:
echo $libdirs -brtl -lgtk -lgdk $my_glib_libs -lintl -lXext -lX11 -lm

The makeC++SharedLib script doesn't work well with commas in the options passed
to it. A better workaround would be to create the libraries without using the
makeC++SharedLib script.
Marking invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 4

16 years ago
verified invalid.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.