Don't get new mail (POP3) -- neither automatically nor manually

VERIFIED WORKSFORME

Status

MailNews Core
Networking: POP
--
blocker
VERIFIED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Boris 'pi' Piwinger, Assigned: Navin Gupta)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020408

This is happening in the newest nightlies. I have never seen it before.

First, whenever I go to Inbox, Mozilla claims to be busy (hourglas showing).
Then occasionally when I switch between account overview and Inbox, no messages
are displayed, but the overview is still shown.

Then after a while (no clear way to reproduce), I don't get any new mail. I have
set to check mail automatically from POP3 (which is reachable). This does not
happen. Chekcking manually, by pressing the Get Msgs button or from the file
menu does nothing. I have to exit Mozilla to get it back to work.

pi
(Assignee)

Comment 1

16 years ago
I have a linux debug build from yesterday and it worksforme. 
(Assignee)

Comment 2

16 years ago
If you can reproduce it more than once, could you list the steps to reproduce 
the bug ? Anything that might be useful for us to reproduce it.
(Reporter)

Comment 3

16 years ago
I can not reproduce it. It just happens after some time. If there is any way to
extract information at this time, I will be glad to provide anything you ask for.

pi
(Assignee)

Comment 4

16 years ago
List the actions you performed when you reproduced it. I mean you started mail 
then clicked where ? selected inbox and so on ..until you see it happen again.

BTW, Are you on a slow connection and how fast is your machine?


(Reporter)

Comment 5

16 years ago
That is the problem. I don't do anything in particular. I read mail and news,
some web pages.

The connection is to a computer at the same switch on 100 MBit. Everything
unchanged to the previous situation (0.9.9 or earlier) where everything worked fine.

pi
(Assignee)

Comment 6

16 years ago
Do you read mail while downloading ?

Comment 7

16 years ago
Created attachment 78500 [details]
TCPDump trace (in ASCII) of POP mail connection

This demonstrates a successful POP connection but nothing is displayed to the
window.

Comment 8

16 years ago
For my trace: I'm having the same problem (0.9.9 release on Win2K). I've
attached an ASCII TCPDump trace (sanitized to remove IP's and password); it
shows what looks to be a successful connection, including STAT and LIST but all
I see now is the hourglass pointer and no mail is displayed. I can successfully
connect with other POP clients.
(Reporter)

Comment 9

16 years ago
Re Comment 6: Downloading is way to fast for reading mail at this time. Usually
the problem appears (or maybe this is just when I notice it) after incativity.

Re Comment 7: I have also seen the effect that new mail is not displayed, but
becomes visible after you change folders.

Additional remark: The server log files shows that the POP3 server was not
accessed when I have this bug. At the same time I am able to check mail by
different means (e.g., fetchmail) from the same machine. So this is not a server
problem.

pi
(Reporter)

Comment 10

16 years ago
Created attachment 78535 [details]
Access log of POP3 server

This list shows the timing of the bug. I have set autmatic mail retrieval every
three minutes. This seems not to work. Other intervals are due to manual
retrieval. I was running Mozilla all the time. Just quitting to get new mail as
seen in the logfile.

pi
(Reporter)

Comment 11

16 years ago
Switching of automatic mail retreival does not change the problem.

Going back to 2002040513 solves the problem.

pi
(Reporter)

Comment 12

16 years ago
No problems so far in Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+)
Gecko/20020412. Since Kyle's description is different (other OS and there is
activity with the server), I mark WORKSFORME.

pi
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 13

16 years ago
ok, good it works! 
Status: RESOLVED → VERIFIED

Comment 14

16 years ago
As of 4/15, the last few nightly builds seem to work OK for me. There seem to be
other problems (e.g. occasionally the mail window won't come up at all, and I
have to completely kill the mozilla process in the Windows Task Manager and
restart Mozilla), but the reported problem seems to have been fixed.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.