Closed Bug 1363686 Opened 4 years ago Closed 4 years ago

Look for llvm-config-4.0 and llvm-config40 in addition to llvm-config

Categories

(Firefox Build System :: General, enhancement)

Unspecified
FreeBSD
enhancement
Not set
normal

Tracking

(firefox55 fixed)

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: jbeich, Assigned: jbeich)

References

Details

Attachments

(2 files)

Assuming LLVM 4.0 now works and will be phased out later than 3.9 let's prefer it if both are installed.
Component: CSS Parsing and Computation → Build Config
Assignee: nobody → jbeich
Comment on attachment 8866300 [details]
Bug 1363686 - Prefer llvm-config aliases for 4.0 on Debian and FreeBSD.

https://reviewboard.mozilla.org/r/137934/#review141140
Attachment #8866300 - Flags: review?(giles) → review+
Comment on attachment 8866301 [details]
Bug 1363686 - Pull LLVM 4.0 for ./mach bootstrap for Stylo on FreeBSD.

https://reviewboard.mozilla.org/r/137936/#review141142
Attachment #8866301 - Flags: review?(giles) → review+
Pushed by rgiles@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bb89dbcd4c8e
Prefer llvm-config aliases for 4.0 on Debian and FreeBSD. r=rillian
https://hg.mozilla.org/integration/autoland/rev/58cbb2e1f39e
Pull LLVM 4.0 for ./mach bootstrap for Stylo on FreeBSD. r=rillian
https://hg.mozilla.org/mozilla-central/rev/bb89dbcd4c8e
https://hg.mozilla.org/mozilla-central/rev/58cbb2e1f39e
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.