WebRTC in Firefox is working or not

RESOLVED INVALID

Status

developer.mozilla.org
API
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: frontegi, Unassigned)

Tracking

Details

(Whiteboard: [specification][type:bug])

Attachments

(4 attachments)

(Reporter)

Description

a year ago
What did you do?
================
1. Using your webrtc samples
2. Not working
3. 

What happened?
==============
Following this tutorial I tried to activate WEBRTC capture.
https://developer.mozilla.org/en-US/docs/Web/API/WebRTC_API/Taking_still_photos

Your Demo is not working:
https://mdn-samples.mozilla.org/s/webrtc-capturestill/

What should have happened?
==========================
Working Webcam !

Is there anything else we should know?
======================================
Is Webtrc supported in Firefox 53 ?
With Chrome I got no problems with your demo or my specific implementation
Created attachment 8866751 [details]
1363690 FF Ask Permission.png

The Firefox Dialog asking for permission to use the camera
Created attachment 8866752 [details]
1363690 FF Permission Denied.png

The demo appearance when I've denied permission
Created attachment 8866754 [details]
1363690 - Permission Details.png

I can click on the icon to show details about the website and the permissions granted. To unblock the camera, click the X next to Blocked Temporarily, and then refresh the page to be asked again.
(Reporter)

Comment 4

a year ago
Created attachment 8866767 [details]
Screenshot_1.png

Hi John, 
the problem was that I had another browser with opened access to the camera.
My camera driver on another laptop is able to share the webcam  in multiple sessions, while the cam on this laptop can work only with one session at a time.

Thanks for your check.

Giulio
(Reporter)

Updated

a year ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.