Broken key navigation in the URL drop-down in high contrast theme

VERIFIED FIXED in Firefox 55



Address Bar
10 months ago
10 months ago


(Reporter: alindeac, Assigned: adw)



55 Branch
Firefox 55
Windows 7
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55 verified)


(Whiteboard: [fxsearch])

[Affected versions]:
- Nightly 55.0a1

[Affected platforms]:
- Windows 7

- Enable a high contrast theme (right click on your Desktop -> Personalize -> from Basic and High Contrast Theme, choose a high contrast theme)

[Steps to reproduce]:
1. Launch Firefox
2. Type "moz" in the URL bar
3. Press the down arrow key to navigate through the autocomplete results and one-offs

[Expected result]:
- Navigation is properly done, the autocomplete results and one-offs are selected one by one.

[Actual result]:
- Navigation is broken, even if in the URL bar you see the links changing (as you hit the down arrow key), the selection does not follow the links.
Please see the screencast for more details:

[Regression range]:

[Additional notes]:
- I could not reproduce this issue on Windows 10. 
- I'll try to reproduce this issue on Windows 8 as soon as possible and post back the results.
Whiteboard: [fxsearch]

Comment 1

10 months ago
I'm not sure what's going on here, but if it's just a coloring problem, the patch in bug 1363407 might fix this since it makes all Windows themes use Highlight as the selected item background color.  Right now we only set the color for the default Windows theme.  Unless I'm missing something it looks like we just don't set a color at all for non-default themes.
Simona, could you try to reproduce this now that bug 1363407 was fixed?
Flags: needinfo?(simona.marcu)
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170515030205

Panos, I can no longer reproduce this issue on the latest Nightly 55.0a1.
Flags: needinfo?(simona.marcu)
Thank you Simona! Marking this as fixed then.
Last Resolved: 10 months ago
Depends on: 1363407
Resolution: --- → FIXED
Assignee: nobody → adw
status-firefox55: affected → fixed
status-firefox-esr52: --- → unaffected
Target Milestone: --- → Firefox 55
Verified as fixed using the latest Nightly 55.0a1 (Build ID: 20170518030213) on Windows 10 x64 and Windows 7 x64.
status-firefox55: fixed → verified


10 months ago
Priority: -- → P1
You need to log in before you can comment on or make changes to this bug.