Mozilla crashes when scrolling a message filter

VERIFIED WORKSFORME

Status

--
critical
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: daniel, Assigned: naving)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Mozilla always crashes when I do stuff with the message filter I'm using. In the
example below I start mozilla mail and then directly go and edit the 
message filter. Mozilla crashes when I scroll the entries in the message 
filter. 

[daniel@fredrik SAT]$ valgrind -v mozilla -mail
==16830== valgrind-20020324, a memory error detector for x86 GNU/Linux.
==16830== Copyright (C) 2000-2002, and GNU GPL'd, by Julian Seward.
==16830== Startup, with flags:
==16830==    --suppressions=/usr/local/lib/valgrind/default.supp
==16830==    -v
==16830== Reading suppressions file: /usr/local/lib/valgrind/default.supp
==16830== Reading syms from /bin/bash
==16830==    object doesn't have a symbol table
==16830==    object doesn't have any debug info
==16830== Reading syms from /lib/ld-2.2.4.so
==16830== Reading syms from /usr/local/lib/valgrind/valgrind.so
==16830== Reading syms from /lib/libtermcap.so.2.0.8
==16830==    object doesn't have a symbol table
==16830==    object doesn't have any debug info
==16830== Reading syms from /lib/libdl-2.2.4.so
==16830== Reading syms from /lib/i686/libc-2.2.4.so
==16830== 
==16830== Conditional jump or move depends on uninitialised value(s)
==16830==    at 0x805ADFD: (within /bin/bash)
==16830==    by 0x8059802: (within /bin/bash)
==16830==    by 0x402E4627: __libc_start_main (../sysdeps/generic/libc-start.c:129)
==16830==    by 0x80593A1: (within /bin/bash)
==16830== 
==16830== Conditional jump or move depends on uninitialised value(s)
==16830==    at 0x805AE05: (within /bin/bash)
==16830==    by 0x8059802: (within /bin/bash)
==16830==    by 0x402E4627: __libc_start_main (../sysdeps/generic/libc-start.c:129)
==16830==    by 0x80593A1: (within /bin/bash)
++16830++ deliver signal 17 immediately: BEGIN
++16830++ deliver signal 17 immediately: END, 328 bbs done
++16830++ deliver signal 17 immediately: BEGIN
++16830++ deliver signal 17 immediately: END, 70 bbs done
==16836== 
==16836== ERROR SUMMARY: 2 errors from 2 contexts (suppressed: 0 from 0)
==16836== 
==16836== 1 errors in context 1 of 2:
==16836== Conditional jump or move depends on uninitialised value(s)
==16836==    at 0x805AE05: (within /bin/bash)
==16836==    by 0x8059802: (within /bin/bash)
==16836==    by 0x402E4627: __libc_start_main (../sysdeps/generic/libc-start.c:129)
==16836==    by 0x80593A1: (within /bin/bash)
==16836== 
==16836== 1 errors in context 2 of 2:
==16836== Conditional jump or move depends on uninitialised value(s)
==16836==    at 0x805ADFD: (within /bin/bash)
==16836==    by 0x8059802: (within /bin/bash)
==16836==    by 0x402E4627: __libc_start_main (../sysdeps/generic/libc-start.c:129)
==16836==    by 0x80593A1: (within /bin/bash)
==16836== IN SUMMARY: 2 errors from 2 contexts (suppressed: 0 from 0)
==16836== 
==16836== malloc/free: in use at exit: 0 bytes in 0 blocks.
==16836== malloc/free: 0 allocs, 0 frees, 0 bytes allocated.
==16836== For a detailed leak analysis,  rerun with: --leak-check=yes
==16836== 
--16836--  dispatch: 564521 basic blocks, 9847 tt_fast misses.
--16836-- translate: new 5683 (75041 -> 997101), discard 0 (0 -> 0).
--16836--       lru: 27 epochs, 0 clearings.
--16836-- reg-alloc: 978 t-req-spill, 189960+6538 orig+spill uis, 26744 total-reg-r.
--16836-- smc-check: 0 checks, 0 fast pass, 0 slow pass, 0 discards.
--16836--    sanity: 418 cheap, 17 expensive checks.
++16830++ deliver signal 17 immediately: BEGIN
++16830++ deliver signal 17 immediately: END, 40 bbs done
++16830++ deliver signal 17 immediately: BEGIN
++16830++ deliver signal 17 immediately: END, 40 bbs done
==16840== 
==16840== ERROR SUMMARY: 2 errors from 2 contexts (suppressed: 0 from 0)
==16840== 
==16840== 1 errors in context 1 of 2:
==16840== Conditional jump or move depends on uninitialised value(s)
==16840==    at 0x805AE05: (within /bin/bash)
==16840==    by 0x8059802: (within /bin/bash)
==16840==    by 0x402E4627: __libc_start_main (../sysdeps/generic/libc-start.c:129)
==16840==    by 0x80593A1: (within /bin/bash)
==16840== 
==16840== 1 errors in context 2 of 2:
==16840== Conditional jump or move depends on uninitialised value(s)
==16840==    at 0x805ADFD: (within /bin/bash)
==16840==    by 0x8059802: (within /bin/bash)
==16840==    by 0x402E4627: __libc_start_main (../sysdeps/generic/libc-start.c:129)
==16840==    by 0x80593A1: (within /bin/bash)
==16840== IN SUMMARY: 2 errors from 2 contexts (suppressed: 0 from 0)
==16840== 
==16840== malloc/free: in use at exit: 0 bytes in 0 blocks.
==16840== malloc/free: 0 allocs, 0 frees, 0 bytes allocated.
==16840== For a detailed leak analysis,  rerun with: --leak-check=yes
==16840== 
--16840--  dispatch: 590117 basic blocks, 12503 tt_fast misses.
--16840-- translate: new 6020 (79231 -> 1052209), discard 0 (0 -> 0).
--16840--       lru: 29 epochs, 0 clearings.
--16840-- reg-alloc: 1004 t-req-spill, 200268+6678 orig+spill uis, 28256
total-reg-r.
--16840-- smc-check: 0 checks, 0 fast pass, 0 slow pass, 0 discards.
--16840--    sanity: 434 cheap, 18 expensive checks.
++16839++ deliver signal 17 immediately: BEGIN
++16839++ deliver signal 17 immediately: END, 40 bbs done
==16839== 
==16839== ERROR SUMMARY: 2 errors from 2 contexts (suppressed: 0 from 0)
==16839== 
==16839== 1 errors in context 1 of 2:
==16839== Conditional jump or move depends on uninitialised value(s)
==16839==    at 0x805AE05: (within /bin/bash)
==16839==    by 0x8059802: (within /bin/bash)
==16839==    by 0x402E4627: __libc_start_main (../sysdeps/generic/libc-start.c:129)
==16839==    by 0x80593A1: (within /bin/bash)
==16839== 
==16839== 1 errors in context 2 of 2:
==16839== Conditional jump or move depends on uninitialised value(s)
==16839==    at 0x805ADFD: (within /bin/bash)
==16839==    by 0x8059802: (within /bin/bash)
==16839==    by 0x402E4627: __libc_start_main (../sysdeps/generic/libc-start.c:129)
==16839==    by 0x80593A1: (within /bin/bash)
==16839== IN SUMMARY: 2 errors from 2 contexts (suppressed: 0 from 0)
==16839== 
==16839== malloc/free: in use at exit: 0 bytes in 0 blocks.
==16839== malloc/free: 0 allocs, 0 frees, 0 bytes allocated.
==16839== For a detailed leak analysis,  rerun with: --leak-check=yes
==16839== 
--16839--  dispatch: 582755 basic blocks, 12377 tt_fast misses.
--16839-- translate: new 5747 (75986 -> 1004447), discard 0 (0 -> 0).
--16839--       lru: 28 epochs, 0 clearings.
--16839-- reg-alloc: 965 t-req-spill, 191238+6370 orig+spill uis, 26992 total-reg-r.
--16839-- smc-check: 0 checks, 0 fast pass, 0 slow pass, 0 discards.
--16839--    sanity: 432 cheap, 18 expensive checks.
++16830++ deliver signal 17 immediately: BEGIN
++16830++ deliver signal 17 immediately: END, 86 bbs done
++16842++ deliver signal 17 immediately: BEGIN
++16842++ deliver signal 17 immediately: END, 40 bbs done
==16842== 
==16842== ERROR SUMMARY: 2 errors from 2 contexts (suppressed: 0 from 0)
==16842== 
==16842== 1 errors in context 1 of 2:
==16842== Conditional jump or move depends on uninitialised value(s)
==16842==    at 0x805AE05: (within /bin/bash)
==16842==    by 0x8059802: (within /bin/bash)
==16842==    by 0x402E4627: __libc_start_main (../sysdeps/generic/libc-start.c:129)
==16842==    by 0x80593A1: (within /bin/bash)
==16842== 
==16842== 1 errors in context 2 of 2:
==16842== Conditional jump or move depends on uninitialised value(s)
==16842==    at 0x805ADFD: (within /bin/bash)
==16842==    by 0x8059802: (within /bin/bash)
==16842==    by 0x402E4627: __libc_start_main (../sysdeps/generic/libc-start.c:129)
==16842==    by 0x80593A1: (within /bin/bash)
==16842== IN SUMMARY: 2 errors from 2 contexts (suppressed: 0 from 0)
==16842== 
==16842== malloc/free: in use at exit: 0 bytes in 0 blocks.
==16842== malloc/free: 0 allocs, 0 frees, 0 bytes allocated.
==16842== For a detailed leak analysis,  rerun with: --leak-check=yes
==16842== 
--16842--  dispatch: 661131 basic blocks, 14644 tt_fast misses.
--16842-- translate: new 5994 (78751 -> 1045759), discard 0 (0 -> 0).
--16842--       lru: 32 epochs, 0 clearings.
--16842-- reg-alloc: 998 t-req-spill, 199079+6556 orig+spill uis, 28147 total-reg-r.
--16842-- smc-check: 0 checks, 0 fast pass, 0 slow pass, 0 discards.
--16842--    sanity: 492 cheap, 20 expensive checks.
++16830++ deliver signal 17 immediately: BEGIN
++16830++ deliver signal 17 immediately: END, 86 bbs done
++16877++ deliver signal 17 immediately: BEGIN
++16877++ deliver signal 17 immediately: END, 40 bbs done
==16877== 
==16877== ERROR SUMMARY: 2 errors from 2 contexts (suppressed: 0 from 0)
==16877== 
==16877== 1 errors in context 1 of 2:
==16877== Conditional jump or move depends on uninitialised value(s)
==16877==    at 0x805AE05: (within /bin/bash)
==16877==    by 0x8059802: (within /bin/bash)
==16877==    by 0x402E4627: __libc_start_main (../sysdeps/generic/libc-start.c:129)
==16877==    by 0x80593A1: (within /bin/bash)
==16877== 
==16877== 1 errors in context 2 of 2:
==16877== Conditional jump or move depends on uninitialised value(s)
==16877==    at 0x805ADFD: (within /bin/bash)
==16877==    by 0x8059802: (within /bin/bash)
==16877==    by 0x402E4627: __libc_start_main (../sysdeps/generic/libc-start.c:129)
==16877==    by 0x80593A1: (within /bin/bash)
==16877== IN SUMMARY: 2 errors from 2 contexts (suppressed: 0 from 0)
==16877== 
==16877== malloc/free: in use at exit: 0 bytes in 0 blocks.
==16877== malloc/free: 0 allocs, 0 frees, 0 bytes allocated.
==16877== For a detailed leak analysis,  rerun with: --leak-check=yes
==16877== 
--16877--  dispatch: 723339 basic blocks, 17936 tt_fast misses.
--16877-- translate: new 6396 (83507 -> 1114027), discard 0 (0 -> 0).
--16877--       lru: 35 epochs, 0 clearings.
--16877-- reg-alloc: 1061 t-req-spill, 212095+6952 orig+spill uis, 30070
total-reg-r.
--16877-- smc-check: 0 checks, 0 fast pass, 0 slow pass, 0 discards.
--16877--    sanity: 545 cheap, 22 expensive checks.
++16830++ deliver signal 17 immediately: BEGIN
++16830++ deliver signal 17 immediately: END, 86 bbs done
Segmentation fault
[daniel@fredrik SAT]$

Comment 1

17 years ago
Please always include build ID in bug-reports.
Duplciate of bug 118815? (fixed around Feb. 19th)

Updated

17 years ago
Keywords: crash
(Reporter)

Comment 2

17 years ago
Mozilla version:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020307

(Thought it said that this data was automatically added to the bug report.)

Comment 3

17 years ago
-->MailNews
Assignee: syd → naving
Component: Editor: Composer → Filters
Product: Browser → MailNews
QA Contact: sujay → laurel

Comment 4

17 years ago
Worksforme with apr9 commercial trunk: mac OS 10.1, mac OS 9.2, linux rh6.2

Comment 5

17 years ago
this is almost certainly a dupe of bug 110165 (which actually fixed 118815). 
please upgrade to a newer build.  
(Reporter)

Comment 6

17 years ago
The sys adm here upgraded to 0.9.9 and the problem disappeared:)

On the other hand valgrind still complains but that's perhaps not
Mozilla's fault?

Thanks for the program,

Daniel



[daniel@fredrik SAT]$ valgrind mozilla -mail  
==20062== valgrind-20020329, a memory error detector for x86 GNU/Linux.
==20062== Copyright (C) 2000-2002, and GNU GPL'd, by Julian Seward.
==20062== For more details, rerun with: -v
==20062== 
==20062== Conditional jump or move depends on uninitialised value(s)
==20062==    at 0x805ADFD: (within /bin/bash)
==20062==    by 0x8059802: (within /bin/bash)
==20062==    by 0x40303627: __libc_start_main (../sysdeps/generic/libc-start.c:129)
==20062==    by 0x80593A1: (within /bin/bash)
==20062== 
==20062== Conditional jump or move depends on uninitialised value(s)
==20062==    at 0x805AE05: (within /bin/bash)
==20062==    by 0x8059802: (within /bin/bash)
==20062==    by 0x40303627: __libc_start_main (../sysdeps/generic/libc-start.c:129)
==20062==    by 0x80593A1: (within /bin/bash)
++20062++ deliver signal 17 immediately: BEGIN
++20062++ deliver signal 17 immediately: END, 328 bbs done
++20062++ deliver signal 17 immediately: BEGIN
++20062++ deliver signal 17 immediately: END, 70 bbs done
==20068== 
==20068== ERROR SUMMARY: 2 errors from 2 contexts (suppressed: 0 from 0)
==20068== malloc/free: in use at exit: 0 bytes in 0 blocks.
==20068== malloc/free: 0 allocs, 0 frees, 0 bytes allocated.
==20068== For a detailed leak analysis,  rerun with: --leak-check=yes
==20068== For counts of detected errors, rerun with: -v
++20062++ deliver signal 17 immediately: BEGIN
++20062++ deliver signal 17 immediately: END, 40 bbs done
++20062++ deliver signal 17 immediately: BEGIN
++20062++ deliver signal 17 immediately: END, 40 bbs done
==20072== 
==20072== ERROR SUMMARY: 2 errors from 2 contexts (suppressed: 0 from 0)
==20072== malloc/free: in use at exit: 0 bytes in 0 blocks.
==20072== malloc/free: 0 allocs, 0 frees, 0 bytes allocated.
==20072== For a detailed leak analysis,  rerun with: --leak-check=yes
==20072== For counts of detected errors, rerun with: -v
++20071++ deliver signal 17 immediately: BEGIN
++20071++ deliver signal 17 immediately: END, 40 bbs done
==20071== 
==20071== ERROR SUMMARY: 2 errors from 2 contexts (suppressed: 0 from 0)
==20071== malloc/free: in use at exit: 0 bytes in 0 blocks.
==20071== malloc/free: 0 allocs, 0 frees, 0 bytes allocated.
==20071== For a detailed leak analysis,  rerun with: --leak-check=yes
==20071== For counts of detected errors, rerun with: -v
++20062++ deliver signal 17 immediately: BEGIN
++20062++ deliver signal 17 immediately: END, 86 bbs done
++20074++ deliver signal 17 immediately: BEGIN
++20074++ deliver signal 17 immediately: END, 40 bbs done
==20074== 
==20074== ERROR SUMMARY: 2 errors from 2 contexts (suppressed: 0 from 0)
==20074== malloc/free: in use at exit: 0 bytes in 0 blocks.
==20074== malloc/free: 0 allocs, 0 frees, 0 bytes allocated.
==20074== For a detailed leak analysis,  rerun with: --leak-check=yes
==20074== For counts of detected errors, rerun with: -v
++20062++ deliver signal 17 immediately: BEGIN
++20062++ deliver signal 17 immediately: END, 86 bbs done
++20109++ deliver signal 17 immediately: BEGIN
++20109++ deliver signal 17 immediately: END, 40 bbs done
==20109== 
==20109== ERROR SUMMARY: 2 errors from 2 contexts (suppressed: 0 from 0)
==20109== malloc/free: in use at exit: 0 bytes in 0 blocks.
==20109== malloc/free: 0 allocs, 0 frees, 0 bytes allocated.
==20109== For a detailed leak analysis,  rerun with: --leak-check=yes
==20109== For counts of detected errors, rerun with: -v
++20062++ deliver signal 17 immediately: BEGIN
++20062++ deliver signal 17 immediately: END, 86 bbs done

Gdk-CRITICAL **: file gdkgc.c: line 51 (gdk_gc_new_with_values): assertion
`window != NULL' failed.
[daniel@fredrik SAT]$ 

Comment 7

17 years ago
marking worksforme based on comment #6
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 8

17 years ago
marking verified worksforme
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.