"Save Image As" doesn't work on images embedded in email

VERIFIED WORKSFORME

Status

--
major
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: mozilla, Assigned: mscott)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.9+) Gecko/20020409
BuildID:    2002040908

I'm unable to save images embedded in email messages. Nothing happenes when I
select "Save Image As" form the context menu.

Reproducible: Always
Steps to Reproduce:
1. Open email message with embedded image
2. Right click on image
3. Select "Save Image As" in context menu

Actual Results:  Nothing happens

Expected Results:  File save dialog should appear

Here's the status of this bug on all of the builds in my cache:

2002030721
won't save "Inbox.jpg"
2002030807
won't save "Inbox.jpg"
2002030822
won't save "Inbox.jpg"
2002030907
won't save "Inbox.jpg"
2002030921
ok
2002031007
ok
2002031021
ok
2002031108
ok
2002031306
ok
2002031308
ok
2002031321
ok
2002031408
ok
2002031508
ok
2002031521
ok
2002031621
ok
2002031721
ok
2002031806
ok
2002031822
ok
2002032406
no option to save image in menu
2002032421
right click on image, move pointer over menu, crash
2002032506
no option to save image in menu
2002032521
no option to save image in menu
2002032606
no option to save image in menu
2002032608
no option to save image in menu
2002032808
no option to save image in menu
2002032908
mailer hosed
2002032911
no option to save image in menu
2002032921
no option to save image in menu
2002040108
no option to save image in menu
2002040211
no option to save image in menu
2002040308
"Save Image As" doesn't work
2002040408
"Save Image As" doesn't work
2002040508
"Save Image As" doesn't work
2002040606
"Save Image As" doesn't work
2002040706
"Save Image As" doesn't work
2002040808
"Save Image As" doesn't work
2002040908
"Save Image As" doesn't work

Comment 1

17 years ago
I've looked at this on this linux build 2002040908 and can't duplicate the
problem.  Embedded images can be saved using the Save Image As from the context
menu.  I've tried this on 2 linux boxes without any problems experienced.

Works for me.

Comment 2

17 years ago
I can confirm, that there definitly WAS a problem, but at least with 2002040803
it is working now.

Comment 3

17 years ago
resolving as wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 4

17 years ago
verifying as wfm
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.