[e10s] Performance issue with large form dropdown

RESOLVED DUPLICATE of bug 1118086

Status

()

P1
normal
RESOLVED DUPLICATE of bug 1118086
a year ago
a year ago

People

(Reporter: philipp, Unassigned)

Tracking

({multiprocess, perf})

54 Branch
Unspecified
Windows
multiprocess, perf
Points:
---

Firefox Tracking Flags

(firefox53 affected, firefox54 affected, firefox55 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

precursor to the STR: you need a microsoft account

- go to https://sysdev.microsoft.com/en-US/Hardware/signup/ 
- sign in with your ms credentials
- click on the drop-down button next to "please find your company"
- firefox hangs for a prolonged period

when switching off e10s the dropdown field opens in a near instant.

i wasn't able to capture a profile with nightly since it was frozen/not responding indefinitely until windows offered to kill it, but with release the freeze was "just" few seconds and the gecko profiler worked:
https://perfht.ml/2qwvqUs
Component: Untriaged → Layout: Form Controls
Keywords: perf
Blocks: 1154677
Keywords: multiprocess
Created attachment 8876370 [details]
Sample of Nightly55.txt

Tested on 55.0a1(BID 20170609030207, macOS 12.12), Firefox hung and no response for several minutes.
From stack trace, it seems main thread was busy doing restyling. 
Attach OSX sampler stack trace for further investigation.
TLin, could you help to investigate what's wrong here?
Flags: needinfo?(tlin)
Priority: -- → P1
This should be a dup of bug 1118086.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(tlin)
Resolution: --- → DUPLICATE
Duplicate of bug: 1118086
You need to log in before you can comment on or make changes to this bug.