Closed Bug 1364167 Opened 4 years ago Closed 1 year ago

Message list displays contents of incorrect folder after repairing folder

Categories

(Thunderbird :: Folder and Message Lists, defect)

defect
Not set
normal

Tracking

(thunderbird_esr68 fixed, thunderbird71 fixed, thunderbird72 fixed)

RESOLVED FIXED
Thunderbird 72.0
Tracking Status
thunderbird_esr68 --- fixed
thunderbird71 --- fixed
thunderbird72 --- fixed

People

(Reporter: jik, Assigned: darktrojan)

References

Details

Attachments

(1 file, 1 obsolete file)

Repro case:

1. Select folder A in the folder list, so that its messages are displayed in the message list.

2. Right click on folder B and open its properties.

3. Click "Repair Folder".

4. Observe that the message list is cleared and replaced with the contents of folder B, even though folder A is still selected in the folder list.

I think this is because gFolderTreeController.rebuildSummary in mail/base/content/folderPane.js calls gFolderDisplay.view.close() and then gFolderDisplay.show(folder) regardless of whether the folder being rebuilt is actually the one currently displayed in the message list.
(Spun off from bug 1363740.)
duplicate of bug 531929?
Component: Mail Window Front End → Folder and Message Lists
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #2)
> duplicate of bug 531929?

I don't think so. That looks like a different issue to me.
Could not reproduce on 52.7.0, Linux x64.  Found this searching for other bugs in "repair folder".
Still happens for me in 52.7.0 Linux x64 and Daily 2018-01-23. No idea why you can't reproduce it.

(In reply to Jonathan Kamens from comment #0)

...
I think this is because gFolderTreeController.rebuildSummary in
mail/base/content/folderPane.js calls gFolderDisplay.view.close() and then
gFolderDisplay.show(folder) regardless of whether the folder being rebuilt
is actually the one currently displayed in the message list.

bingo? Is the code still the same?

Flags: needinfo?(geoff)

and then there is wada's bug 553859

Looks like the answer to me.

Assignee: nobody → geoff
Status: NEW → ASSIGNED
Flags: needinfo?(geoff)
Attachment #9108031 - Flags: review?(jorgk)
Duplicate of this bug: 553859
Comment on attachment 9108031 [details] [diff] [review]
1364167-repair-folder-change-1.diff

How did you get to this bug?
Attachment #9108031 - Flags: review?(jorgk) → review+
Attachment #9108031 - Flags: approval-comm-esr68?
Attachment #9108031 - Flags: approval-comm-beta+
Target Milestone: --- → Thunderbird 72.0

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/42e6d3683bda
When repairing a folder only re-display it if it is the current one. r=jorgk

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Attachment #9108031 - Flags: approval-comm-esr68? → approval-comm-esr68+

I'm seeing the following in TB 68.3:
I repair the current folder and the messages in the list go blank when hovered. It becomes good when I switch to another folder and back. That's pretty ugly.

Alice, can you please check this for me:
STR:
Local folder with some messages, right-click, repair folder.
Hover the mouse over some messages in the folder and they go blank.

Was this caused by this bug. I don't repair folders much, but I've never seen this.

Flags: needinfo?(alice0775)

Wait, I'll try a local backout.

Yep, went broken here :-(

Flags: needinfo?(alice0775)
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/b8b151fb1635
Backed out changeset 42e6d3683bda for causing a blank thread pane after repair folder. a=backout
Status: RESOLVED → REOPENED
Flags: needinfo?(geoff)
Resolution: FIXED → ---

Backout from branches:
https://hg.mozilla.org/releases/comm-beta/rev/a67ce4c2f2bc92c519b2e9b8ca65a8c337f1e0f2
https://hg.mozilla.org/releases/comm-EDIT-esr68/rev/6cfca925b7a577a92ba72f1857e04eb70bad6512

(I was using my PTO to sort through some mail and in the end repaired a folder and found this issue. I think it's worse than the original bug.)

That's why we don't uplift patches until they've had time on the branches.

Attachment #9108031 - Attachment is obsolete: true
Flags: needinfo?(geoff)
Attachment #9111115 - Flags: review+

Personally, I don't trust Daily or Beta exposure. To my knowledge, no one complained on Daily or 71 beta 3. So IMHO putting it into 68.3 (pre-release) and actually using it myself wasn't such a bad idea after all.

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/39ed67f1df1f
Do not change folders when repairing a folder other than the current one. r=jorgk

Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED
Attachment #9111115 - Flags: approval-comm-esr68?
Attachment #9111115 - Flags: approval-comm-beta+
Attachment #9108031 - Flags: approval-comm-esr68+
Attachment #9108031 - Flags: approval-comm-beta+
Attachment #9111115 - Flags: approval-comm-esr68? → approval-comm-esr68+

Geoff, thunderbird_esr68 isn't set here and by the looks of it on none of the bugs landed on ESR after the beginning of December. At some stage we had a BMO query in the release notes that used that information. I was never a friend of that.

You need to log in before you can comment on or make changes to this bug.