Closed Bug 1364191 Opened 4 years ago Closed 4 years ago

Thunderbird activity indicator never shown

Categories

(Thunderbird :: Theme, defect)

52 Branch
defect
Not set
normal

Tracking

(thunderbird_esr5254+ fixed, thunderbird54 fixed, thunderbird55 fixed)

RESOLVED FIXED
Thunderbird 55.0
Tracking Status
thunderbird_esr52 54+ fixed
thunderbird54 --- fixed
thunderbird55 --- fixed

People

(Reporter: moz-bugs-2017, Assigned: Paenglab)

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:49.0) Gecko/20100101 Firefox/49.0 SeaMonkey/2.46
Build ID: 20161213183751

Steps to reproduce:

The activity indicator is not being shown when e-mail is checked or sent, even though it is on the toolbar.
Activity-Indicator-01.png --> shows that the indicator is on the toolbar at the right.

Activity-Indicator-02.png --> note how the activity indicator is not being shown as e-mail is being checked and downloaded.
Check tools > Error console for errors.
Start Thunderbird in safe mode - https://support.mozilla.org/en-US/kb/safe-mode-thunderbird
If it works, then post the name of the addon you find to be causing the problem.
Flags: needinfo?(moz-bugs-2017)
Yes, I see that, too. So you place the Activity Indicator during "Customize..." and as soon as you close the customise panel, it's gone, right? Aceman, Richard, how is this supposed to work?
Flags: needinfo?(richard.marti)
Flags: needinfo?(acelists)
Attached patch throbber.patchSplinter Review
The throbber is only shown when it's busy. But now there is never one shown because it points to a not existing image.
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(richard.marti)
Attachment #8866949 - Flags: review?(acelists)
Flags: needinfo?(moz-bugs-2017)
Flags: needinfo?(acelists)
Comment on attachment 8866949 [details] [diff] [review]
throbber.patch

Why do I get the boring reviews with fading tab labels and not this exiting one with movement and action :-(

Anyway, I saw it work, so r+. I can change the reviewer when landing this.
Attachment #8866949 - Flags: review?(acelists) → review+
(In reply to Jorg K (GMT+2) from comment #6)
> Why do I get the boring reviews with fading tab labels and not this exiting
> one with movement and action :-(

'Exiting' could be dangerous to the health :)

> Anyway, I saw it work, so r+. I can change the reviewer when landing this.

Thanks :)
I would have finished it, but I broke my build again.
Component: Untriaged → Theme
Keywords: checkin-needed
OS: Unspecified → All
Hardware: Unspecified → All
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Sorry, I should have asked before approving this, but better late than never:
1) Uplift required? To TB 54? When did this break?
2) Where does loading.png come from? toolkit/themes/shared/icons/loading.png ?
3) What is notloading.png?
   https://hg.mozilla.org/comm-central/rev/0c69fb6641073a7046cb1d9a8acf968d53f98072#l1.17
   I compared it visually to loading.png and it looks pretty much the same. Do we need two?
Flags: needinfo?(richard.marti)
Comment on attachment 8866949 [details] [diff] [review]
throbber.patch

[Approval Request Comment]
User impact if declined: no throbber
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): loy

(In reply to Jorg K (GMT+2) from comment #9)
> Sorry, I should have asked before approving this, but better late than never:
> 1) Uplift required? To TB 54? When did this break?

Yes, see above

> 2) Where does loading.png come from? toolkit/themes/shared/icons/loading.png?

Correct

> 3) What is notloading.png?

It's used in the customizs window. This is a not animated throbber.

> https://hg.mozilla.org/comm-central/rev/
> 0c69fb6641073a7046cb1d9a8acf968d53f98072#l1.17
>    I compared it visually to loading.png and it looks pretty much the same.
> Do we need two?

Two? What do you mean with two? There is only loading.png in global.
Flags: needinfo?(richard.marti)
Attachment #8866949 - Flags: approval-comm-esr52?
Attachment #8866949 - Flags: approval-comm-beta?
Comment on attachment 8866949 [details] [diff] [review]
throbber.patch

I still don't know when that broke, what is the regressing bug?
Attachment #8866949 - Flags: approval-comm-beta? → approval-comm-beta+
It was bug 1317142 there I probably forgot to fix the path for the throbber.
Attachment #8866949 - Flags: approval-comm-esr52? → approval-comm-esr52+
You need to log in before you can comment on or make changes to this bug.