Closed Bug 1364347 Opened 3 years ago Closed 3 years ago

JSON parse error when saving profile

Categories

(Core :: Gecko Profiler, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1364442

People

(Reporter: lth, Unassigned)

Details

Attachments

(1 file)

I'll attach a tar with the TC (it originates in bug 1353292).  It untars as a directory called 'Test 1' (sorry).

This is in this morning's mozilla-inbound code, changeset:   357986:27fb70fdc744, built for Release.

This is with a freshly installed Gecko Profiler add-on.

I enable the profiler, load the TC's HTML from file, then wait for the TC to signal "Done".  You want a Release build for this.  I then click on "Capture profile" in the profile extension's window.

The output in the window is this:

  Couldn't retrieve the profile from the gecko profiler addon.
  Error was "SyntaxError: JSON.parse: expected double-quoted property name at
  line 2 column 16 of the JSON data". The full stack has been written to the
  Web Console.

The output in the console is this:

SyntaxError: JSON.parse: expected double-quoted property name at line 2 column 16 of the JSON data
Stack trace:
h@https://perf-html.io/f61f20a02823d7843650.bundle.js:30:3050
e/<@https://perf-html.io/f61f20a02823d7843650.bundle.js:30:7398
r@https://perf-html.io/f61f20a02823d7843650.bundle.js:40:17593
l/<@https://perf-html.io/f61f20a02823d7843650.bundle.js:40:19022
s/</e[t]@https://perf-html.io/f61f20a02823d7843650.bundle.js:40:17769
r@https://perf-html.io/f61f20a02823d7843650.bundle.js:28:20510
r/<@https://perf-html.io/f61f20a02823d7843650.bundle.js:28:20616
i@https://perf-html.io/f61f20a02823d7843650.bundle.js:35:376
R/<@https://perf-html.io/f61f20a02823d7843650.bundle.js:35:498
l@https://perf-html.io/f61f20a02823d7843650.bundle.js:34:26728
 f61f20a02823d7843650.bundle.js:33:7103

Unhandled promise rejection SyntaxError: JSON.parse: expected double-quoted property name at line 2 column 16 of the JSON data
Stack trace:
h@https://perf-html.io/f61f20a02823d7843650.bundle.js:30:3050
e/<@https://perf-html.io/f61f20a02823d7843650.bundle.js:30:7398
r@https://perf-html.io/f61f20a02823d7843650.bundle.js:40:17593
l/<@https://perf-html.io/f61f20a02823d7843650.bundle.js:40:19022
s/</e[t]@https://perf-html.io/f61f20a02823d7843650.bundle.js:40:17769
r@https://perf-html.io/f61f20a02823d7843650.bundle.js:28:20510
r/<@https://perf-html.io/f61f20a02823d7843650.bundle.js:28:20616
i@https://perf-html.io/f61f20a02823d7843650.bundle.js:35:376
R/<@https://perf-html.io/f61f20a02823d7843650.bundle.js:35:498
l@https://perf-html.io/f61f20a02823d7843650.bundle.js:34:26728
 f61f20a02823d7843650.bundle.js:35:729
Ditto with a freshly downloaded Nightly build and a clean profile and a freshly installed profiler and any random web page.  (I used https://axis-of-eval.org which is plain html, no JS, plugins, images.)
Appears this may be a dup of 1364442.
Duping forward because bug 1364442 has a bit more concrete information about where the bug is.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1364442
You need to log in before you can comment on or make changes to this bug.