when asked to get mail using pop3 account, mail is deleted rather than downloaded

VERIFIED WORKSFORME

Status

MailNews Core
Movemail
--
critical
VERIFIED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Daniel Andrews, Assigned: Adam D. Moss)

Tracking

({dataloss})

Trunk
x86
Linux
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020313
BuildID:    2002031312

Using my pop3 Demon e-mail account.  New mail is being deleted rather then
downloaded to my machine.  My Virgin Internet account seems unaffected.  This
has happened 3 - 4 times now and all settings appear the same.  Can no longer
use Mozilla Mail!

Reproducible: Always
Steps to Reproduce:
1.  Mail check as start show waiting unread pop3 mail
2. Press "get messages"


Actual Results:  3. says "no new mail" and mail is deleted from the server
4. check using Demon web-mail to confirm unread message has been removed
5. Do not appear in reader window

Expected Results:  Both unread and read pop3 mail used to appear in reader
window using ver 9.7

Updated

16 years ago
Keywords: dataloss

Comment 1

16 years ago
I was going to report the same problem myself, I am using build 2002040410 and
this problem is not related to a single account.

Mozilla fetch mail from three accounts: POP3 at online.no, POP3 at
nameplanet.com and IMAP at nith.no, and destroy mail from all accounts.

The sad thing is that the program is working fine sometimes, I let it fetch mail
as usual and some of the mails is coming as is should.

Updated

16 years ago
QA Contact: gayatri → esther

Comment 2

16 years ago
daniel@dandrews.demon.co.uk - 2002031312 is too old a build to report bugs
against now. The problem you are reporting may well have been fixed already. 

Could you please download a recent nightly build from
<ftp://ftp.mozilla.org/pub/mozilla/nightly/>, and then let us know if you 
still see this problem?

Thanks,

Alistair Lewars

Comment 3

16 years ago
Addition to previous confirmation report on bug (136442):

"when asked to get mail using pop3 account, mail is deleted rather than downloaded"

I tried to reproduce this bug, using the steps stated by the reporter, 
and could not.

Build: 2002060308
Platform: PC
OS: Linux 2.4.18

Someone please verify.  Thanks.

Comment 4

16 years ago
Since reproducing this bug seems unsuccessful, I'm marking this uncomfirmed bug
as WORKSFORME.  Daniel, please feel free to reopen this bug if reproducible in a
current build.  Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 5

16 years ago
I don't understand the steps, but I regularly create new profiles adding 2 pop
accounts and at least 2 imap accounts.  I Get Msg daily with these accounts with
daily builds.  I have not seen problems with my pop mail being deleted during
downloads.  The only time I saw something remotely similiar was when I was
testing deleting POP accounts.  If I added a POP account  then deleted it and
immediately added it again without exiting I would see the mail messages I had
download during the first login, then when deleted and added the account back
again I was seeing the cached view of the previous download, but when I did a
Get Msg the status said it retrieved messages but it no new messages were
displayed (because it was displaying the cached thread list of the account when
it was 1st added) after exitng and launching again I then saw the thread list of
the newly downloaded messages.  This was fixed a while back.  I will verify as
worksforme, if reporter still sees this and can add specific steps to reproduce
reopen and we'll try again. 
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.