Closed Bug 1364478 Opened 3 years ago Closed 3 years ago

The new-profile ping is never sent if it was generated when having telemetry sending disabled

Categories

(Toolkit :: Telemetry, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: madalin.cotetiu, Assigned: Dexter)

References

Details

(Whiteboard: [measurement:client])

Attachments

(1 file)

Steps to reproduce:
1. Open Firefox nightly with a clean profile.
2. After the telemetry sending policy banner is displayed disable telemetry sending.
3. Restart Firefox  -- new-profile ping is generated
4. Enable telemetry sending
5. Restart Firefox

Expected results:
The new-profile should be sent after enabling telemetry sending.

Actual results:
The new-profile is not sent after enabling telemetry.

Notes/Issues:
Build identifier: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Priority: -- → P1
Whiteboard: [measurement:client]
Thanks for filing this Madalin. I think we can live with this behaviour, which is expected:

- when the time for sending the 'new-profile' ping comes, the user has not given the consent for sending it, so we're not sending it. If, after hours, days, months the prefs is turned back on, then the profile is no longer 'new' and doesn't change the fact that user didn't consent sending the ping;
- this should affect a very small fraction of our users.

It would be very useful to add all the edge cases that we find to the ping documentation, as a new section, in this bug.
Assignee: nobody → alessio.placitelli
Comment on attachment 8868047 [details]
Bug 1364478 - Add edge case documentation for the 'new-profile' ping.

https://reviewboard.mozilla.org/r/139640/#review142980

::: toolkit/components/telemetry/docs/data/new-profile-ping.rst:43
(Diff revision 1)
> +If the ``new-profile`` ping is set to be generated and Telemetry is disabled, the ping is not
> +sent. If Telemetry is turned back on at a later time, the ``new-profile``ping won't still be
> +sent.

Discussing this, what we really want is probably a clear list of conditions and resulting behaviors.
This can include non-edge-case scenarios as well.
Attachment #8868047 - Flags: review?(gfritzsche)
Comment on attachment 8868047 [details]
Bug 1364478 - Add edge case documentation for the 'new-profile' ping.

https://reviewboard.mozilla.org/r/139640/#review143432

This looks really helpful.
Can you have Madalin review this for completeness?

::: toolkit/components/telemetry/docs/data/new-profile-ping.rst:45
(Diff revision 3)
> +- **The ping is generated at the browser shutdown, on a new profile, after the privacy policy is displayed**:
> +  ``new-profile`` is sent immediately using the :doc:`../internals/pingsender`.
> +- **The ping is generated at the browser shutdown (triggered by OS shutdown), on a new profile, after the privacy
> +  policy is displayed**: ``new-profile`` is saved to disk and sent next time the browser restarts.

Can you group this into one list item, with two sub items?

::: toolkit/components/telemetry/docs/data/new-profile-ping.rst:49
(Diff revision 3)
> +
> +- **The ping is generated at the browser shutdown, on a new profile, after the privacy policy is displayed**:
> +  ``new-profile`` is sent immediately using the :doc:`../internals/pingsender`.
> +- **The ping is generated at the browser shutdown (triggered by OS shutdown), on a new profile, after the privacy
> +  policy is displayed**: ``new-profile`` is saved to disk and sent next time the browser restarts.
> +- **The ping is generated before the privacy policy is displayed**: ``new-profile`` is saved to disk and sent

Is this actually possible?

::: toolkit/components/telemetry/docs/data/new-profile-ping.rst:51
(Diff revision 3)
> +- **The ping is set to be generated and Telemetry is disabled**: ``new-profile`` is not sent nor generated again
> +  if Telemetry is turned back on.

"... is never sent, even if Telemetry is turned back on later."?

::: toolkit/components/telemetry/docs/data/new-profile-ping.rst:55
(Diff revision 3)
> +- **User performs a profile refresh and the ping was already sent**: ``new-profile`` will not be sent again.
> +- **User performs a profile refresh and the ping was not sent**: ``new-profile`` will be generated and sent.

Can you group this into one list item, with two sub items?
Attachment #8868047 - Flags: review?(gfritzsche) → review+
Comment on attachment 8868047 [details]
Bug 1364478 - Add edge case documentation for the 'new-profile' ping.

https://reviewboard.mozilla.org/r/139640/#review143432

> Is this actually possible?

That's a very extreme edge case: user starts the browser with a new profile then closes it before the choices infobar is displayed. So very short first session.
Comment on attachment 8868047 [details]
Bug 1364478 - Add edge case documentation for the 'new-profile' ping.

Hi Madalin!

Since you're taking care of the QA part on this, would you mind reviewing this patch? Can you think of anything else that needs to be added?
Attachment #8868047 - Flags: review?(madalin.cotetiu)
We should also document the next scenario : 

1.Create a new profile and start Firefox
2.Immediately(before data choice infobar is displayed), go to about:support and Refresh Nightly

Expected results:
After Refresh , the new-profile ping is sent in 30 mins or after shut-down

Actual results:
The new profile ping is not sent at all
Comment on attachment 8868047 [details]
Bug 1364478 - Add edge case documentation for the 'new-profile' ping.

https://reviewboard.mozilla.org/r/139640/#review144512
Attachment #8868047 - Flags: review?(madalin.cotetiu) → review+
Pushed by alessio.placitelli@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/e517be6b801e
Add edge case documentation for the 'new-profile' ping. r=gfritzsche,madalin.cotetiu+500525
https://hg.mozilla.org/mozilla-central/rev/e517be6b801e
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
You need to log in before you can comment on or make changes to this bug.