Closed Bug 13645 Opened 21 years ago Closed 21 years ago

Folding/hiding menu toolbar while XP menu is in dropdown state crashes RAPTORHTML

Categories

(Core :: XUL, defect, P3, major)

x86
Windows 98
defect

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: icos, Assigned: saari)

Details

APPRUNNER caused an invalid page fault in
module RAPTORHTML.DLL at 0177:6053db1b.
1) click file menu so it is in a dropdown state
2) click the "folder" bar just to the left of the file menu
3) the file menu has dissapeared and the XP Menu is still there. Move your mouse
over the XP Menu and you get this:

Registers:
EAX=00000001 CS=0177 EIP=6053db1b EFLGS=00010206
EBX=0063fa50 SS=017f ESP=0063f858 EBP=0063f85c
ECX=0063f888 DS=017f ESI=015d2e00 FS=53a7
EDX=00000001 ES=017f EDI=00000000 GS=0000
Bytes at CS:EIP:
8b 06 51 ff 75 10 ff 75 0c 56 ff 90 84 00 00 00
Stack dump:
0160af64 0063f87c 605bce17 02051840 0141ef10 0063fa58 0063f888 00000000 01ab36b0
0063f8c8 605bc684 0141ef10 00000001 0160af64 0063fa10 01434c68


sept 10 build.
Assignee: trudelle → saari
Target Milestone: M12
Reproduced crash using latest opt bits, good catch icos@digitalchat.net!
In case the steps aren't clear, step 2 is to collapse the menubar that you
clicked in in step 1.
reassigning to saari as p3 for m12
QA Contact: beppe → claudius
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → WORKSFORME
I can't reproduce this in 10/20 build, resolving as worksforme
Status: RESOLVED → VERIFIED
marking VERIFIED wfm with the 1999102008 build
You need to log in before you can comment on or make changes to this bug.