Do not resume from cache for failed downloads

VERIFIED DUPLICATE of bug 142312

Status

SeaMonkey
Download & File Handling
--
enhancement
VERIFIED DUPLICATE of bug 142312
16 years ago
13 years ago

People

(Reporter: TGOS, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.9+) Gecko/20020405
BuildID:    2002040503

When you saved a webpage in the past, Mozilla re-downloaded the full page, even
though it was displayed right now and thus must have been completely in memory
(the download manager opened nonetheless). This was stupid behavior and got fixed.

Unfortunately, it didn't get any better. Now Mozilla stores either the current
HTML file or the full page (with all pictures) to disk (whatever you chose), the
way it is displayed on screen right now. This is not desirable either, because I
may have stopped loading the full page and thus the stored page is incomplete.

Reproducible: Always
Steps to Reproduce:
1. Store an incompletely loaded webpage to disk.


Actual Results:  The page is still incomplete on disk (the HTML data is there,
but only the pictures loaded so far are there for example)

Expected Results:  Mozilla should remember whether the last page was loaded
completely or not, if it was, Mozilla can simply store it from memory, no
download manager window must open. If it was not loaded completely, Mozilla
should re-download it completely from the server and store that to disk, a
download manager window should appear.

Often I open HTML pages, that are several MB in size (lists up to 16 MB for
example) and in that case I don't want to wait till Mozilla displays the whole
list, because Mozilla gets very slow if pages get larger than maybe 2 MB. In the
past I could simply stop after the first few lines, chose save to disk and
Mozilla's download manager opened, getting the whole page and storing it to a
file. Now, I will just get the first few lines of the file if I do that.

In case there was POST data sent to get the current page, Mozilla should warn
the user before resending it the same way it warns user when refreshing the
page, otherwise it may be a problem if you store your credit card transaction
result to disk and the transaction is happening a second time. If the user
chooses to not send post data again, Mozilla should store whatever it has in
memory of the page right now (that's the way it is doing it now), otherwise send
the post data again and download the page completely again. Of course, if the
user did not interrupt loading of the page, Mozilla can directly take it from
memory and thus don't have to ask if the POST data should be sent again.

I don't know how other browsers do it, but it makes no sense to download a page
again that is completely in memory, that's right. However, it also makes no
sense to store an incompletely page to disk.

Comment 1

16 years ago
I'm not sure If I understand you, do you want Mozilla to delete cahed HTML
files/images that is not completed? Seems like pointless to me, If Moz/Win
should crash when downloading a site I think it would be a waste of time to wait
for the whole page to Re-load yet again...
(Reporter)

Comment 2

16 years ago
> I'm not sure If I understand you, do you want Mozilla to delete cahed HTML
> files/images that is not completed?

No, I want that Mozilla ignores cache when storing files or images to disk that
were not loaded completely before.

It's really simple:
Use a variable and set it false when you start loading a page, when you finished
loading a page, that it to true. However, if the loading process is interrupted
befor it could finish normally, the variable stays false.

If a user chooses Save Page As and the variable is true, simply store it from
the cache, if the variable is false, ignore the cache and re-get the page from
the server.


In the past Mozilla never used the chache, so when I started downloading a page
and after a while I recognized that this page is very big and I rather want to
store it to disk than viewing it online, I could simply stop loading, choose
Save Page As and got the file on disk and it was complete (because Mozilla
downloaded the page of server and did not stored the corrupted one, which is
corrupt because I interrupted the loading process). However, Mozilla did it
always like that, which was annoying as well: if the page is completely in the
cache and not corrupted through an interruption, why not taking it from the cache?

But if it was not loaded completely, what sense does it make to store a
corrupted page?

Comment 3

15 years ago
per comment #2, this is a duplicate

*** This bug has been marked as a duplicate of 142312 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Summary: Mozilla should not store incomplete pages to disk → Do not resume from cache for failed downloads
mass-verification of Duplicates.

mail search string for bugspam: SolarFlaresAreTheCause
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.