Closed Bug 1364623 Opened 6 years ago Closed 6 years ago

Reading mode isn't working anymore on websites that worked before

Categories

(Toolkit :: Reader Mode, defect)

55 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1364056
Tracking Status
firefox53 --- unaffected
firefox54 --- unaffected
firefox55 --- fixed

People

(Reporter: ptiyugi, Unassigned)

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170512030203

Steps to reproduce:

I went to a website hosting a novel I'm reading, and activated reading mode.
Here's the website: https://eromangaweb.wordpress.com/eross-volume-1-chapter-5/

I'm using Firefox Nightly with last updates (55.0a1).


Actual results:

Reading mode told me it couldn't load the article using the page.


Expected results:

It should have entered reading mode. It worked until a few days ago. Even chapters I've already read with reading mode don't work anymore.

It still works with Firefox Developer Edition.
It just worked after trying again and again.
Component: Untriaged → Reader Mode
Product: Firefox → Toolkit
[Tracking Requested - why for this release]:

Regression range:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2b6f6881a24a726364054aa69031927e2f3fc5fa&tochange=120d8562d4a53e4f78bd86c6f5076f6db265e5a3

Gijs, as you are in charge of Reader Mode and you have some bugfixes (bug 1358248, bug 1360842) in this pushlog, could it be related? (I don't have access to these bug reports)
Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Ever confirmed: true
Flags: needinfo?(gijskruitbosch+bugs)
Keywords: regression
This is a duplicate of the less-accurately-summarized bug 1364056. Sorry. I will do my best to get it fixed today.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(gijskruitbosch+bugs)
Resolution: --- → DUPLICATE
Duplicate of bug: 1364056
You need to log in before you can comment on or make changes to this bug.