Firefox 52 doesn't respect operating system settings of date and hour clock system format

VERIFIED FIXED in Firefox 56

Status

()

defect
P1
normal
VERIFIED FIXED
2 years ago
a year ago

People

(Reporter: Virtual, Assigned: gandalf)

Tracking

(Depends on 1 bug, {nightly-community, regression, ux-consistency})

52 Branch
Firefox 56
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr45 unaffected, firefox-esr52 wontfix, firefox53 wontfix, firefox54+ wontfix, firefox55+ wontfix, firefox56+ verified)

Details

(Whiteboard: [fixed by patches from bug # 1379420 and bug #1380916] [set "intl.regional_prefs.use_os_locales" to "true" in about:config])

+++ This bug was initially created as a clone and followup of Bug #1343768 +++


[Tracking Requested - why for this release]: Regression


STR:
1. Change the date system format on Windows 7 [64-bit] to "YYYY-MM-DD" in "Region and Language" in "Control Panel" [maybe restart of operating system will be needed]
2. Start Mozilla Firefox Nightly (inbound build) [64-bit]
3. Open the Library
4. Select "Views" button to see menu, and in "Show columns" submenu, check "Added"
5. See that wrong date system format is still used ("M/D/YYYY"),
instead of set date system format in operating system options ("YYYY-MM-DD")
No longer blocks: 1364786
Has Regression Range: --- → yes
Has STR: --- → yes
(Assignee)

Comment 1

2 years ago
What's your os locale and Firefox locale?
Is it fixed in 55? (All bugs you referenced are 53-55, so my guess is that you're misattributing the bug)
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1364786
(Assignee)

Updated

2 years ago
Flags: needinfo?(Virtual)
(In reply to Zibi Braniecki [:gandalf][:zibi] from comment #1)
> What's your os locale and Firefox locale?

PL (Poland) / none (as inbound builds don't have one, so probably standard English)
but I can confirm this on all OS locales and all Firefox locales.
Please see and try STR from comment #0, as it should be reproducible on all operating systems per my tests.


(In reply to Zibi Braniecki [:gandalf][:zibi] from comment #1)
> Is it fixed in 55? (All bugs you referenced are 53-55, so my guess is that
> you're misattributing the bug)

No, it's not fixed in latest Mozilla Firefox Nightly 55.0a1 [inbound build].
All Mozilla Firefox versions starting from 52 are affected, see "Version:" and "Tracking Flags:".
Summary: Firefox 52 doesn't respect operating system settings of date system format → Firefox 52 doesn't respect operating system settings of date and hour clock system format
(Assignee)

Comment 4

2 years ago
Yep, we currently don't use OS date/time when OS language mismatches with Firefox language. You can install `pl` Firefox nightly from nightly.mozilla.org [0] to get Firefox to follow your OS settings.

This may change within 55 timeframe - I'm going to spend next week revisiting the language matching policy against Windows HIG.
It's a matter of product locale integrity vs. OS integration. For example, it seems that Edge follows OS regional settings while Opera and Chrome don't (at all).
Gecko is somewhere in-between, since we'll follow the settings if the language portion of the locale matches (say, en-AU + en-GB or fr-CA and fr-FR).

I'll file a bug to revisit this on Monday, and will update the dependency on this one.


[0] https://www.mozilla.org/en-US/firefox/nightly/all/?q=Polish,%20Polski
(Assignee)

Updated

2 years ago
Flags: needinfo?(gandalf)
Track 54+/55+ as the date/time format mismatches with OS setting.
Whatever we put into place here, it is too late to change things in 53.
(Assignee)

Comment 7

2 years ago
I filed bug 1366134 where we're discussing the best strategy for cross-language OS regional settings.

This bug can be either marked as a dupe of 1366134 or a blocked by bug 1366134.
Flags: needinfo?(gandalf)
Too late for 54 as 54 RC is released. Mark 54 won't fix.

Updated

2 years ago
Depends on: 1383463
(Assignee)

Comment 9

2 years ago
I'm not sure if it should be marked as FIXED or WONTFIX, because the behavior changed on purpose. In 56 we added `intl.regional_prefs.use_os_locales` perf that brings back the old behavior for advanced users. 

In bug 1379910 we're planning to add a Preferences UI for that toggle, but I'm not sure if UX team will want it and when will someone decide to add it.

In any way, I don't think that there's a value in keeping this bug open as for this particular combination (OS in one locale, Firefox in a completely different one), Firefox's default behavior will be to follow Firefox locale for regional preferences unless OS and Firefox are in the same language.

Marking as WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
(In reply to Zibi Braniecki [:gandalf][:zibi] from comment #9)
> I'm not sure if it should be marked as FIXED or WONTFIX, because the
> behavior changed on purpose. In 56 we added
> `intl.regional_prefs.use_os_locales` perf that brings back the old behavior
> for advanced users. 
> 
> In bug 1379910 we're planning to add a Preferences UI for that toggle, but
> I'm not sure if UX team will want it and when will someone decide to add it.
> 
> In any way, I don't think that there's a value in keeping this bug open as
> for this particular combination (OS in one locale, Firefox in a completely
> different one), Firefox's default behavior will be to follow Firefox locale
> for regional preferences unless OS and Firefox are in the same language.
> 
> Marking as WONTFIX.

Let's mark this issue as FIXED, as it could be fixed by setting "intl.regional_prefs.use_os_locales" to "true" in about:config, as you wrote and everything works properly.

Thank you very much for your hard work! \o/
Status: RESOLVED → VERIFIED
Depends on: 1379420, 1380916
Resolution: WONTFIX → FIXED
Whiteboard: [fixed by patches from bug # 1379420 and bug #1380916] [set "intl.regional_prefs.use_os_locales" to "true" in about:config]
Target Milestone: --- → Firefox 56
You need to log in before you can comment on or make changes to this bug.