Missing Tasks: "Mail & Newsgroups", "IRC Chat" and "Address Book" are GONE!

RESOLVED DUPLICATE of bug 125489

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 125489
16 years ago
13 years ago

People

(Reporter: Tilo Sloboda, Assigned: Matti)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; SunOS 5.8 sun4u)
BuildID:    2002031103

When starting Mozilla for the *SECOND* time, the menu options
CTRL+2, CTRL+3 and CTRL+5  in the "Tasks" menue are GONE!
that is: "Mail & Newsgroups", "IRC Chat" and "Address Book" are GONE!

This is *very* annoying... because there is no more access to the
Mail and the Address Book..  the keyboard shortcuts are gone as well!

Reproducible: Always
Steps to Reproduce:
1. rm -rf mozilla;   tar -zxvf mozilla-sparc-sun-solaris-0.9.9.tar.gz
2. mozilla/mozilla &   # to start mozilla

3. type CTRL+Q to exit
4. mozilla/mozilla & 

after step 2, the menu options are still there
after step 4, these menu options are GONE .. aargh!

the problem is 100% reproducable

Actual Results:  My guess is that somehow Mozilla messes up it's installation
directory.. 

a diff between a brand-new mozilla directory, and a messed up
one shows this: 

ts134341@tilo% diff -r mozilla mozilla-bad
Only in mozilla-bad/chrome: chrome.rdf
Only in mozilla-bad: component.reg
Only in mozilla-bad/components: xpti.dat

contents of one of those files might be responsible for the bug.

the problem is 100% reproducable and the contents of those three
files are always changed 100% the same after the first program
termination. 

Expected Results:  same menues for every startup..

When mozilla starts the first time, out of a freshly un-tar'ed 
directory, it says: 

*** Registering -venkman handler.
*** Registering -chat handler.
*** Registering x-application-irc handler.
*** Registering irc protocol handler.
*** Registering smime account manager extension.

Gdk-CRITICAL **: file gdkgc.c: line 51 (gdk_gc_new_with_values): assertion
`window != NULL' failed.


if it is started for the second time, out of that same directory, 
it only says: 

Gdk-CRITICAL **: file gdkgc.c: line 51 (gdk_gc_new_with_values): assertion
`window != NULL' failed.

Well - the GdK bug is a separate issue - but i think the problem 
might be connected to the handlers not  being registered upon 
startup of mozilla..
(Reporter)

Comment 1

16 years ago
ooops - i forgot the OS version again.. duh!

svbld> uname -a
SunOS tilo 5.8 Generic_111433-02 sun4u sparc SUNW,Ultra-5_10
(Reporter)

Comment 2

16 years ago
THIS IS A Mozilla 0.9.9 BUG!   above User-Agent info is WRONG!

   Mozilla/0.9.9 [en] (X11; U; SunOS 5.8 sun4u)

Comment 3

16 years ago
This is a duplicate of bug 125489.
    
All of the tasks show up correctly only the first time you use a particular
build.  There's a work around explained in bug 125489. Basically, you change the
permissions on a file so it doesn't get corrupted.


*** This bug has been marked as a duplicate of 125489 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
Please verify that the fix in the original bug works for you. I qa only
networking:file, so you need to make sure this worked for the problem described
here.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.