navigator.sendBeacon should not force application/octet-stream as content-type for ArrayBuffer

RESOLVED FIXED in Firefox 55

Status

()

Core
DOM
RESOLVED FIXED
10 months ago
9 months ago

People

(Reporter: baku, Assigned: baku)

Tracking

unspecified
mozilla55
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox55 fixed)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Assignee)

Description

10 months ago
This is a follow up of 1329298 comment 11.
(Assignee)

Comment 2

10 months ago
Created attachment 8867750 [details] [diff] [review]
beacon.patch

Per spec, we should force any special content-type if the body extractor returns null.
Assignee: nobody → amarchesini
Attachment #8867750 - Flags: review?(bugs)

Comment 3

10 months ago
Comment on attachment 8867750 [details] [diff] [review]
beacon.patch

We really need wpt tests for this, but I have no idea how to write such.
Please ask jgraham or someone.
Attachment #8867750 - Flags: review?(bugs) → review+

Comment 4

10 months ago
Comment on attachment 8867750 [details] [diff] [review]
beacon.patch

Wait, so what content type is used after this patch?

Comment 5

10 months ago
I guess nothing, which is per Fetch spec.
(Assignee)

Comment 6

10 months ago
Created attachment 8868299 [details] [diff] [review]
beacon2.patch
Attachment #8868299 - Flags: review?(james)
(Assignee)

Comment 7

9 months ago
Created attachment 8868411 [details] [diff] [review]
beacon2.patch
Attachment #8868299 - Attachment is obsolete: true
Attachment #8868299 - Flags: review?(james)
Attachment #8868411 - Flags: review?(annevk)
(Assignee)

Comment 8

9 months ago
Created attachment 8868444 [details] [diff] [review]
beacon2.patch

step_timeout instead of setTimeout
Attachment #8868411 - Attachment is obsolete: true
Attachment #8868411 - Flags: review?(annevk)
Attachment #8868444 - Flags: review?(annevk)

Comment 9

9 months ago
Comment on attachment 8868444 [details] [diff] [review]
beacon2.patch

Review of attachment 8868444 [details] [diff] [review]:
-----------------------------------------------------------------

Looks reasonable.
Attachment #8868444 - Flags: review?(annevk) → review+

Comment 10

9 months ago
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2e7b01803f79
navigator.sendBeacon should not force application/octet-stream as content-type for ArrayBuffer, r=smaug
https://hg.mozilla.org/integration/mozilla-inbound/rev/862bbeb666a0
WPT for sendBeacon and content-type header, r=annevk

Comment 11

9 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/2e7b01803f79
https://hg.mozilla.org/mozilla-central/rev/862bbeb666a0
Status: NEW → RESOLVED
Last Resolved: 9 months ago
status-firefox55: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla55

Updated

9 months ago
Duplicate of this bug: 1366500
You need to log in before you can comment on or make changes to this bug.