Bug 1364950 (PaulJayD)

Version 53.0.2 'audio' tag disappears

RESOLVED INVALID

Status

()

Core
Audio/Video: Playback
RESOLVED INVALID
6 months ago
3 months ago

People

(Reporter: Paul Dickler, Unassigned, NeedInfo)

Tracking

53 Branch
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 months ago
Created attachment 8867768 [details]
audio.html

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170504105526

Steps to reproduce:

For both a local file, and a filie delivered via http, the 'audio' player disappears and no sound is heard.
I'v execute the same files on Chrome, IE, Edge and athey all work correctly.


Actual results:

The 'audio'  player disappears and no sound is heard.


Expected results:

THe play should persist and sound play.

Updated

6 months ago
Component: Untriaged → Audio/Video
Product: Firefox → Core
Component: Audio/Video → Audio/Video: Playback
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
(Reporter)

Comment 1

6 months ago
Created attachment 8870402 [details]
audio2.html

Firefox auto-updated to 53.0.3, and I changed the format of the 'audio' tag, and
it still disappears with no sound.
The tag does work in Chrome, IE, Edge, and Opera.
Those examples don't make sense with a file path. Try src="http://..."
Can you provide a link that reproduces the issue?
Flags: needinfo?(paul)
(Reporter)

Comment 4

5 months ago
The following link is valid until my isp changes my ip address:
 
   http://100.1.68.96:2468/kliksy/audiotest.html

Load the page, and then click the line with "test..." to place the element in the right column (the active queue).
The mp3 should play. If not, click the Play/Pause button as required.

Thanks.
(In reply to Paul Dickler from comment #4)
> Load the page, and then click the line with "test..." to place the element
> in the right column (the active queue).
> The mp3 should play. If not, click the Play/Pause button as required.

It plays for me on Firefox but it looks like something is stuck in a loop making the audio element wider.
Jet - is a difference in layout behaviour beteen us and other browsers causing this effect?
Flags: needinfo?(bugs)

Comment 7

4 months ago
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #6)
> Jet - is a difference in layout behaviour beteen us and other browsers
> causing this effect?

Please file a separate bug if you want us to debug this test app's layout. A comment like this in the HTML seems to indicate that the layout is not our bug:

<!-- &fix don't understand this: without = big left margin -->


The CSS Layout would not cause audio to not play back.
Flags: needinfo?(bugs)
(Reporter)

Comment 8

3 months ago
I'm closing this 'bug' -
I discovered that my CSS attempted to reduce the height of the <audio> player to 36px. This previously worked. Now, however, it causes the tag to disappear.
Thanks to all for any attention paid to the problem.

Paul
Alias: PaulJayD
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.