[reader mode] a lot of pages "failed to load the page" in latest nightly

RESOLVED DUPLICATE of bug 1364056

Status

()

Toolkit
Reader Mode
RESOLVED DUPLICATE of bug 1364056
8 months ago
8 months ago

People

(Reporter: flore, Assigned: baku)

Tracking

({nightly-community})

55 Branch
nightly-community
Points:
---

Firefox Tracking Flags

(firefox-esr45 unaffected, firefox-esr52 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 months ago
Since a few days, some news sites I'm used to read fail to load the page in reader mode. Too many sites at the same time to be a coincidence.

Example (among many other) : http://www.leparisien.fr/politique/videos-a-berlin-macron-promet-une-refondation-historique-de-l-europe-15-05-2017-6951876.php

I ran a mozregression and got the following regression window:
INFO: Last good revision: 2b6f6881a24a726364054aa69031927e2f3fc5fa
INFO: First bad revision: 120d8562d4a53e4f78bd86c6f5076f6db265e5a3
INFO: Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2b6f6881a24a726364054aa69031927e2f3fc5fa&tochange=120d8562d4a53e4f78bd86c6f5076f6db265e5a3
(Reporter)

Updated

8 months ago
Has Regression Range: --- → yes
(Reporter)

Comment 1

8 months ago
It could be related to bug 1363309 for which a patch was landed at this moment.

STR: 
0. go to a page on some site that usually works in reader mode (example: http://www.leparisien.fr/politique/videos-a-berlin-macron-promet-une-refondation-historique-de-l-europe-15-05-2017-6951876.php)
1. click on the reader mode icon

Actual results: Get "Failed to load the article from page"

Expected results: The text is correctly displayed like it was a few days ago
Flags: needinfo?(amarchesini)
(Assignee)

Updated

8 months ago
Assignee: nobody → amarchesini
Flags: needinfo?(amarchesini)
(Assignee)

Comment 2

8 months ago
Created attachment 8868175 [details] [diff] [review]
fileReader.patch

I don't think my patches for FileReader are related to this issue, but, debugging it, I found that the error was:

Full message: TypeError: can't access dead object
Full stack: this.ReaderMode._readerParse<@resource://gre/modules/ReaderMode.jsm:469:19
TaskImpl_run@resource://gre/modules/Task.jsm:319:42

'doc' has been already released after the reading of its content. We should grab the document URI before.
Attachment #8868175 - Flags: review?(gijskruitbosch+bugs)

Comment 3

8 months ago
Comment on attachment 8868175 [details] [diff] [review]
fileReader.patch

Review of attachment 8868175 [details] [diff] [review]:
-----------------------------------------------------------------

Please r+ my patch in bug 1364056, of which this is a dupe.
Attachment #8868175 - Flags: review?(gijskruitbosch+bugs)

Updated

8 months ago
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1364056
You need to log in before you can comment on or make changes to this bug.