Closed Bug 1365066 Opened 5 years ago Closed 5 years ago

stylo: object-position and object-fit don't work on <video poster>

Categories

(Core :: CSS Parsing and Computation, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1364591

People

(Reporter: manishearth, Unassigned)

References

(Blocks 1 open bug)

Details

<video poster> lets you specify a background image to be used in the video. This image can be manipulated with object-fit and object-position.


Posters work in Stylo (for video, img, and object, and embed elements), but they aren't affected by the object-fit/object-position properties in the case of video elements.


Causes the failures of layout/reftests/image/image-object-*-with-background-1.html and layout/reftests/w3c-css/submitted/images3/object-* (44 tests)

Video posters are NAC, so it's probably a bug there.
I expect the patch for bug 1364591 fixes all of this stuff.  Just waiting for the servo CI to get its act together before I can land the test expectations...
Depends on: 1364591
Status: NEW → RESOLVED
Closed: 5 years ago
No longer depends on: 1364591
Resolution: --- → DUPLICATE
Duplicate of bug: 1364591
You need to log in before you can comment on or make changes to this bug.