Text highlight is not cleared when closing find bar in PDF viewer

VERIFIED FIXED in Firefox 65

Status

()

defect
P5
minor
VERIFIED FIXED
2 years ago
9 months ago

People

(Reporter: arai, Assigned: Snuffleupagus)

Tracking

unspecified
Firefox 65
x86_64
macOS
Points:
---

Firefox Tracking Flags

(firefox59 wontfix, firefox60 wontfix, firefox61 wontfix, firefox65 verified)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Steps to reproduce:
  1. open Nightly with clean profile on OSX
  2. open https://www.bugzilla.org/docs/4.2/en/pdf/Bugzilla-Guide.pdf
  3. hit command+F to open Find bar
  4. find "Bugzilla"
  5. hit esc key

Actual result:
  "Bugzilla" in the page is kept highlighted after closing Find bar

Expected result:
  Highlight is cleared when closing Find bar
Priority: -- → P5
Duplicate of this bug: 1437479
This is still an issue in 61. From the comments in bug 143479, sounds like the regression range isn't clear (and that the issue goes back at least to 2012).
Posted patch findbarclose.patch (obsolete) — Splinter Review
Brendan, I'm sure if you're allowed to review the changes to the findbar.js file but if not I hope that are able to suggest a suitable reviewer.
Assignee: nobody → jonas.jenwald
Attachment #9015616 - Flags: review?(bdahl)
Duplicate of this bug: 803456
Comment on attachment 9015616 [details] [diff] [review]
findbarclose.patch

Everything looks good to me, but I'll have Paolo check the findbar.js portion.
Attachment #9015616 - Flags: review?(paolo.mozmail)
Attachment #9015616 - Flags: review?(bdahl)
Attachment #9015616 - Flags: review+
Comment on attachment 9015616 [details] [diff] [review]
findbarclose.patch

Looks good to me. Thanks for fixing this bug!
Attachment #9015616 - Flags: review?(paolo.mozmail) → review+
Keywords: checkin-needed
Hi, there are conflicts while applying your patch
applying findbarclose.patch
patching file browser/base/content/test/general/browser_findbarClose.js
Hunk #1 FAILED at 23
1 out of 1 hunks FAILED -- saving rejects to file browser/base/content/test/general/browser_findbarClose.js.rej
patch failed, unable to continue (try -v)
patch failed, rejects left in working directory
errors during apply, please fix and qrefresh findbarclose.patch

Please provide an updated patch. Thank you!
Clearing the checkin-needed.
Flags: needinfo?(jonas.jenwald)
Keywords: checkin-needed
Attachment #9015616 - Attachment is obsolete: true
Flags: needinfo?(jonas.jenwald)
Attachment #9020014 - Flags: review+
Keywords: checkin-needed
Pushed by ebalazs@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e55f02b20a9c
Clear all find highlights, in the PDF Viewer, when the findbar is closed. r=bdahl,paolo
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/e55f02b20a9c
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Though platform is set as Mac OS X, from duplicate bug 1437479 we know this affected all 3 platforms. 

I have reproduced this in Arch linux (x86_64) on Nightly 55.0a1 (2017-05-15) (64-bit)

I can verify that this issue is fixed in latest Nightly

Build ID 	20181205102000
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0
QA Whiteboard: [bugday-20181205]
I have reproduced this bug with Nightly 55.0a1 (2017-05-15) on Windows 7, 64 Bit!
This bug's fix is verified with latest Nightly!

Build ID 	20181207093029
User Agent 	Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0
[bugday-20181205]
As per comment 11 and comment 12, I am marking this as verified fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.