WindowsError: [Error 206] The filename or extension is too long

RESOLVED DUPLICATE of bug 1364072

Status

Firefox Build System
General
RESOLVED DUPLICATE of bug 1364072
a year ago
3 months ago

People

(Reporter: mats, Unassigned)

Tracking

Trunk
All
Windows

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
Got this error in a Try run (Windows 2012 opt and Windows 2012 x64 opt):

WindowsError: [Error 206] The filename or extension is too long: 'y:\\hg-shared\\8ba995b74e18334ab3707f27e9eb8f4e37ba3d29\\.hg\\data/mobile/android/tests/browser/chrome/tp5/amazon.com/www.amazon.com/Kindle-Wireless-Reader-Wifi-Graphite/dp/B002Y27P3M/%5C%22http%3A/g-ecx.images-amazon.com/images/G/01/kindle/shasta/photos' [log…]

 
abort: The filename or extension is too long: 'y:\hg-shared\8ba995b74e18334ab3707f27e9eb8f4e37ba3d29\.hg\data/mobile/android/tests/browser/chrome/tp5/amazon.com/www.amazon.com/Kindle-Wireless-Reader-Wifi-Graphite/dp/B002Y27P3M/%5C%22http%3A/g-ecx.images-amazon.com/images/G/01/kindle/shasta/photos' [log…] 


https://treeherder.mozilla.org/#/jobs?repo=try&revision=b64e4893b79105c0556e0a64c3c89eefe1298b4a&selectedJob=99206843
I think someone just updated Mercurial or switched to robustcheckout in automation configs. I can't think of any other reason you'd hit this. My guess is things will start failing across automation pretty soon and whatever change was made will get backed out.
Almost certainly related to work done in bug 1364072 a few hours ago.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1364072

Updated

3 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.