Fix margin left for autocomplete-richlistbox

RESOLVED INVALID

Status

()

Firefox
Theme
RESOLVED INVALID
a year ago
8 months ago

People

(Reporter: magicp, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox53 unaffected, firefox54 unaffected, firefox55 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Created attachment 8868003 [details]
autocomplete-richlistbox.png

[Steps to reproduce]
1. Start latest Nightly (e.g. Build ID: 20170515030205)
2. Enter any words in awesome bar

[Actual Results]
margin left is too large.

[Expected Results]
Back to previous styles.

[Regression Range]
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=0645deeb4caa1de3fa2f238005500f77e457eacd&tochange=a46c4ea1cf309c23fa89c06a985d2102a7a0260a
(Reporter)

Updated

a year ago
status-firefox53: --- → unaffected
status-firefox54: --- → unaffected
status-firefox55: --- → affected
This is a side effect of moving some controls to the left of the urlbar, because the autocomplete text aligns horizontally with the urlbar text. I wouldn't call it a regression, but the search team should probably think about whether they want to change this. Panos, needinfo'ing you to make sure search is aware of the issue.
Flags: needinfo?(past)
(Also note that we will eventually center the urlbar, so this is issue will definitely get worse). Stephen, I haven't seen any Photon urlbar autocomplete mockups yet, did I just miss those? What's the plan there?
Flags: needinfo?(shorlander)
Aligning the results with the typed text has been the intent behind Stephen's current (previous?) design, so this looks fine to me.
Flags: needinfo?(past)
(Reporter)

Comment 4

a year ago
Created attachment 8869636 [details]
autocomplete-richlistbox-2.png

(In reply to Panos Astithas [:past] (please needinfo?) from comment #3)
> Aligning the results with the typed text has been the intent behind
> Stephen's current (previous?) design, so this looks fine to me.

If so, attached image case is wrong?
(In reply to magicp from comment #4)
> Created attachment 8869636 [details]
> autocomplete-richlistbox-2.png
> 
> (In reply to Panos Astithas [:past] (please needinfo?) from comment #3)
> > Aligning the results with the typed text has been the intent behind
> > Stephen's current (previous?) design, so this looks fine to me.
> 
> If so, attached image case is wrong?

Drew might know if we ignore alignment when the search bar is moved around.
Flags: needinfo?(adw)
There's a threshold past which we don't try to align the margin anymore.  I forget what it is exactly.  It may be a number of toolbar items or a number of points/pixels.  But that screenshot definitely hits it. :-)

Good point about what to do when the urlbar is centered, though.
Flags: needinfo?(adw)
This logic here: https://dxr.mozilla.org/mozilla-central/rev/9851fcb0bf4d855c36729d7de19f0fa5c9f69776/browser/base/content/urlbarBindings.xml#1696

If there are more than two toolbar items between the window edge and the urlbar, then we stop trying to align.
Per the comments above this is working as intended, so resolving this bug.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → INVALID
Flags: needinfo?(shorlander)
You need to log in before you can comment on or make changes to this bug.