creating/editing events with google calendar fails when existing Google cookies are present

NEW
Unassigned

Status

()

Core
General
--
critical
11 months ago
9 months ago

People

(Reporter: Christos Bacharakis, Unassigned)

Tracking

unspecified
x86_64
Linux
Points:
---

Firefox Tracking Flags

(firefox54 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 months ago
Created attachment 8868089 [details]
Screenshot from 2017-05-15 12-44-34.png

Every time I try to interact with mozilla's corporate google calendar (reply to an event, create an event, delete an event) I get a "failed" message.

You can also check the attached image for the output of the console.

This issue has also been noticed from other colleagues as well. 

Firefox version: 52.0.2

1. Steps to reproduce:
2. Open Mozilla's corporate google calendar
3a. Try to create a new event
3b. Try to respond to an event
3c. Try to delete an event

Comment 1

11 months ago
I've been experiencing this too as have a number of other people in the office.
People on IRC report that clearing all google cookies fixes this.

I can confirm that it didn't work for me in my existing profile, but worked in a fresh profile.

I think it's unlikely to be a JS engine problem.
Component: JavaScript Engine → General
Summary: [qf] Failing to interact with google calendar → creating/editing events with google calendar fails when existing Google cookies are present
And as the screenshot points out -- the difference visible in the Network devtools tab between the working case and broken case is that the POST to https://calendar.google.com/calendar/event returns 200 OK vs 403 Forbidden status.  I don't see other obvious differences, and the error in the upper line in the screenshot doesn't seem relevant since it occurs in both the working and broken case.

Comment 4

11 months ago
I just ran into this problem too on Beta54.
status-firefox54: --- → affected

Comment 5

11 months ago
I use Google Calendar regularly and just hit the problem today on Nightly. Deleting the Google Calendar cookies solved the problem.
Comment hidden (off-topic)
Comment hidden (off-topic)
Comment hidden (off-topic)
You need to log in before you can comment on or make changes to this bug.