[commands] Window requires focus for _execute_browser_action to work

RESOLVED DUPLICATE of bug 1325697

Status

()

Toolkit
WebExtensions: General
P5
normal
RESOLVED DUPLICATE of bug 1325697
7 months ago
7 months ago

People

(Reporter: jkt, Unassigned)

Tracking

54 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 months ago
I'm on Ubuntu 16.04 with Nightly and other builds (mainly tested on unbranded 54).

STR

1. Open browser
2. Select the location bar
3. Do the shortcut command (in my case Ctrl+Y)
4. Browser action doesn't open


Was using https://github.com/mozilla/testpilot-containers/pull/509 to test.

This may be a duplicate with: https://bugzilla.mozilla.org/show_bug.cgi?id=1365176
(Reporter)

Comment 1

7 months ago
As Jaws pointed out this is the Redo action on text input which the URL bar is swallowing. The same bug exists for normal input fields also.

I personally think web extensions should override this in the URL bar case when there isn't anything to Redo.

The following might want to continue to work:
1. Ctrl+z
2. Ctrl+r

Comment 2

7 months ago
duping
Flags: needinfo?(amckay)
Priority: -- → P5

Comment 3

7 months ago
This sounds like a dupe of bug 1325697.
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Flags: needinfo?(amckay)
Resolution: --- → DUPLICATE
Duplicate of bug: 1325697
You need to log in before you can comment on or make changes to this bug.