Attempting to Get Msgs while fetchmail is retrieving mail locks mail windoow in "waiting" state

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
17 years ago
11 years ago

People

(Reporter: lists, Assigned: adam)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020409
BuildID:    2002040908

When fetchmail is retrieving mail, an attempt to Get Msgs in the movemail
account chamges the cursor over the mail window into a "waiting" small watch
face icon, and does not retrieve the mail.  This state does not clear.  Closing
and re-opening the mail window has no effect.  Only closing and reopening
mozilla clears the state.

Reproducible: Sometimes
Steps to Reproduce:
1.Wait until some external system indication that fetchmail is retrieving mail
2.Click Get Msgs icon in the main mail window
3.

Actual Results:  Icon changes to "wait" icon and remains in that state.
Mail is not retrieved.

Expected Results:  Mail is retrived and icon rapidly returns to normal state

Reproducibility is given as "sometimes", but it has already happened to me
twice, and I have only noticed this in the past two days.

Comment 1

17 years ago
A dup of Bug 135658  ?

What does your pop server response while fetchmail is running and another
program tries to get the mails at the same time? (see telnetlog of 135658)
something like that? :/
(Reporter)

Comment 2

17 years ago
I have jsut seen this (in 2002041008) when no mail was being fetched (although
it is possible that fetchmail was checking an empty server at the time, though I
doubt it.)  Same symptoms - attempt to Get Msgs fails, and leaves the
"wristwatch" cursor.

Adrian, movemail doesn't go to the server, just to the local mailbox after
fetchmail has retrieved the mail, so I don't think it is the same sort of bug.
(Reporter)

Comment 3

17 years ago
This one may not be in the right category.  I have just seen the same symptom
after *sending* a mail message.  It seems to be happening much too frequently to
simply be co-inciding with fetchmail's 10 minute poll activity.
(Reporter)

Comment 4

17 years ago
This problem MAY be related to the more general navigation failures that keep
cropping up, e.g. 127059.  I just recently had to shut down my mail windows, and
trying to re-open the main mail window by using the envelope icon on the bottom
of the browser window did nothing.  I had to restart mozilla to get things
working again.
(Reporter)

Comment 5

17 years ago
This situation seems to be cleared by selecting another account, then
re-selecting the movemail account at the main mail window account panel.
(Reporter)

Comment 6

17 years ago
I haven't seen this for a couple of weeks.  I'm marking it as WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.