Crash in aaa_walk_convex_edges

RESOLVED DUPLICATE of bug 1364778

Status

()

--
critical
RESOLVED DUPLICATE of bug 1364778
a year ago
a year ago

People

(Reporter: philipp, Unassigned)

Tracking

({crash, regression})

55 Branch
Unspecified
Linux
crash, regression
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55 fixed)

Details

(crash signature)

(Reporter)

Description

a year ago
This bug was filed from the Socorro interface and is 
report bp-c409e5b7-66de-48fb-984f-440bb0170516.
=============================================================
Crashing Thread (0)
Frame 	Module 	Signature 	Source
0 	libxul.so 	aaa_walk_convex_edges(SkAnalyticEdge*, AdditiveBlitter*, int, int, int, int, bool) 	
1 	libxul.so 	SkScan::AAAFillPath(SkPath const&, SkRegion const&, SkBlitter*, bool) 	
2 	libxul.so 	SkScan::AAAFillPath 	gfx/skia/skia/src/core/SkScan_AAAPath.cpp:1840
3 	libxul.so 	SkScan::AntiFillPath(SkPath const&, SkRasterClip const&, SkBlitter*) 	
4 	libxul.so 	SkDraw::drawDevPath(SkPath const&, SkPaint const&, bool, SkBlitter*, bool) const 	
5 	libxul.so 	SkDraw::drawPath(SkPath const&, SkPaint const&, SkMatrix const*, bool, bool, SkBlitter*) const 	
6 	libxul.so 	SkBitmapDevice::drawPath(SkPath const&, SkPaint const&, SkMatrix const*, bool) 	
7 	libxul.so 	SkCanvas::onDrawPath(SkPath const&, SkPaint const&) 	
8 	libxul.so 	mozilla::gfx::DrawTargetSkia::Fill(mozilla::gfx::Path const*, mozilla::gfx::Pattern const&, mozilla::gfx::DrawOptions const&) 	
9 	libxul.so 	mozilla::SVGGeometryFrame::Render(gfxContext*, unsigned int, gfxMatrix const&, unsigned int) 	
10 	libxul.so 	mozilla::SVGGeometryFrame::PaintSVG(gfxContext&, gfxMatrix const&, mozilla::gfx::IntRectTyped<mozilla::gfx::UnknownUnits> const*, unsigned int) 	
11 	libxul.so 	nsDisplaySVGGeometry::Paint(nsDisplayListBuilder*, nsRenderingContext*) 	
12 	libxul.so 	mozilla::FrameLayerBuilder::PaintItems(nsTArray<mozilla::FrameLayerBuilder::ClippedDisplayItem>&, mozilla::gfx::IntRectTyped<mozilla::gfx::UnknownUnits> const&, gfxContext*, nsRenderingContext*, nsDisplayListBuilder*, nsPresContext*, mozilla::gfx::IntPointTyped<mozilla::gfx::UnknownUnits> const&, float, float, int) 	
13 	libxul.so 	mozilla::FrameLayerBuilder::DrawPaintedLayer(mozilla::layers::PaintedLayer*, gfxContext*, mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&, mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&, mozilla::layers::DrawRegionClip, mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&, void*) 	
14 	libxul.so 	mozilla::layers::BasicPaintedLayer::PaintThebes(gfxContext*, mozilla::layers::Layer*, void (*)(mozilla::layers::PaintedLayer*, gfxContext*, mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&, mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&, mozilla::layers::DrawRegionClip, mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&, void*), void*) 	
15 	libxul.so 	mozilla::layers::BasicLayerManager::PaintSelfOrChildren(mozilla::layers::PaintLayerContext&, gfxContext*) 	
16 	libxul.so 	mozilla::layers::BasicLayerManager::PaintLayer(gfxContext*, mozilla::layers::Layer*, void (*)(mozilla::layers::PaintedLayer*, gfxContext*, mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&, mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&, mozilla::layers::DrawRegionClip, mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&, void*), void*) 	
17 	libxul.so 	mozilla::layers::BasicLayerManager::PaintSelfOrChildren(mozilla::layers::PaintLayerContext&, gfxContext*) 	
18 	libxul.so 	mozilla::layers::BasicLayerManager::PaintLayer(gfxContext*, mozilla::layers::Layer*, void (*)(mozilla::layers::PaintedLayer*, gfxContext*, mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&, mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&, mozilla::layers::DrawRegionClip, mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&, void*), void*) 	
19 	libxul.so 	mozilla::layers::BasicLayerManager::EndTransactionInternal(void (*)(mozilla::layers::PaintedLayer*, gfxContext*, mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&, mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&, mozilla::layers::DrawRegionClip, mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&, void*), void*, mozilla::layers::LayerManager::EndTransactionFlags) 	
20 	libxul.so 	mozilla::FrameLayerBuilder::PaintItems(nsTArray<mozilla::FrameLayerBuilder::ClippedDisplayItem>&, mozilla::gfx::IntRectTyped<mozilla::gfx::UnknownUnits> const&, gfxContext*, nsRenderingContext*, nsDisplayListBuilder*, nsPresContext*, mozilla::gfx::IntPointTyped<mozilla::gfx::UnknownUnits> const&, float, float, int) 	
...

these crashes start showing up on 55.0a1 starting with build 20170513100302 an later and are coming mainly from installations on linux and android.
could it be related to bug 1340627 which landed the day before?
Flags: needinfo?(lsalzman)
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(lsalzman)
Resolution: --- → DUPLICATE
Duplicate of bug: 1364778
(Reporter)

Comment 2

a year ago
fixed via bug 1364691
status-firefox55: affected → fixed
You need to log in before you can comment on or make changes to this bug.