Hard to find the wizard to import data from another browser

RESOLVED DUPLICATE of bug 731144

Status

()

Firefox
Migration
--
major
RESOLVED DUPLICATE of bug 731144
9 months ago
3 months ago

People

(Reporter: Kyle Sanderson, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36

Steps to reproduce:

Attempted to import data from Chrome after using Chrome and Firefox for 3 months.


Actual results:

I wasn't able to find the wizard...


Expected results:

The wizard should be easily find-able underneath the hamburger menu.
(Reporter)

Updated

9 months ago
Severity: normal → major

Updated

9 months ago
Component: Untriaged → Migration

Comment 1

9 months ago
There's no deception involved, it's just not a feature people use regularly, so it doesn't have its own entry in the hamburger menu. It comes up automatically when you initially install Firefox if it's never been installed on that machine (to help you get set up), and there are entry points from the bookmarks manager as well as the saved logins dialog (which you can see, among other places, in the Firefox Options).

We could potentially add a toplevel item in the bookmarks menu (and the same menu for the bookmarks/library toolbar button), I guess? Would that help?
Summary: Import Data from another Browser deceptively difficult → Hard to find the wizard to import data from another browser
(Reporter)

Comment 2

9 months ago
(In reply to :Gijs from comment #1)
> There's no deception involved, it's just not a feature people use regularly,
> so it doesn't have its own entry in the hamburger menu. It comes up
> automatically when you initially install Firefox if it's never been
> installed on that machine (to help you get set up), and there are entry
> points from the bookmarks manager as well as the saved logins dialog (which
> you can see, among other places, in the Firefox Options).
> 
> We could potentially add a toplevel item in the bookmarks menu (and the same
> menu for the bookmarks/library toolbar button), I guess? Would that help?

Absolutely. For our customers on ESR we suppress all popups on startup, this is critical in education with kids bouncing from machine to machine. There's a couple teachers who were looking for the import tool, and, embarrassingly enough I was stumbling through it until I realized it was hidden underneath the Library popup... They (schools) primarily use Chrome for obvious reasons, but there's a few users who like Firefox and I'd like to cater to all crowds.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 731144
You need to log in before you can comment on or make changes to this bug.