Closed Bug 1365364 Opened 3 years ago Closed 2 years ago

[geckoview] nsIBrowserDOMWindow impl not working in e10s

Categories

(GeckoView :: General, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1368187

People

(Reporter: snorp, Unassigned)

References

Details

Attachments

(1 file)

When running under e10s, links with target=_blank and such are not going through the nsIBrowserDOMWindow implementation that we set. ContentParent looks for it in the TabParent when you click a link, and the nsFrameLoader is responsible for transferring it from the nsGlobalWindow to TabParent. The latter seems to be happening before we set the one on nsGlobalWindow.
Comment on attachment 8873920 [details]
Bug 1365364 - Set up nsIBrowserDOMWindow correctly in GeckoView

https://reviewboard.mozilla.org/r/145304/#review149276
Attachment #8873920 - Flags: review+
Component: Embedding: APIs → GeckoView
Product: Core → Firefox for Android
Version: unspecified → Trunk
jchen: snorp: what's the status here?
Flags: needinfo?(snorp)
Flags: needinfo?(nchen)
Landed in bug 1368187.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(nchen)
Resolution: --- → DUPLICATE
Duplicate of bug: 1368187
Flags: needinfo?(snorp)
Product: Firefox for Android → GeckoView
You need to log in before you can comment on or make changes to this bug.