Troubleshooting Information tab fails to open [[Exception NS_ERROR_XPC_CANT_MODIFY_PROP_ON_WN in aboutRedirector.js]

RESOLVED DUPLICATE of bug 1362461

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 1362461
a year ago
a year ago

People

(Reporter: ssitter, Unassigned)

Tracking

55 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
Using a fresh profile with Thunderbird 55.0a1 (2017-05-15). When trying to open Help > Troubleshooting I get an empty tab with title "Loading...". Error Console shows:

NS_ERROR_XPC_CANT_MODIFY_PROP_ON_WN: Cannot modify properties of a WrappedNative  aboutRedirector.js:55

[Exception... "Component returned failure code: 0x80570034 (NS_ERROR_XPC_CANT_MODIFY_PROP_ON_WN) [nsIWebNavigation.loadURIWithOptions]"  nsresult: "0x80570034 (NS_ERROR_XPC_CANT_MODIFY_PROP_ON_WN)"  location: "JS frame :: chrome://global/content/bindings/browser.xml :: loadURIWithFlags/< :: line 150"  data: no]

TypeError: aOldTab._ext.glodaSearchBox is undefined  searchBar.js:58:7

TypeError: aTab._ext.glodaSearchBox is undefined  searchBar.js:63:9

Comment 1

a year ago
That's a little hard to believe since we have a test "test-about-support.js" that checks the content of the trouble shooting page (about:support). However, I tried yesterday's Daily (2017-05-14) and it doesn't work.

Aceman, can you please take a look here. Do we have a regression range? Alice, can you check this, still working on 2015-05-08.
Flags: needinfo?(alice0775)
Flags: needinfo?(acelists)

Comment 2

a year ago
Hmm, I ran
  mozmake SOLO_TEST=content-tabs/test-about-support.js mozmill-one
on a local build of latest trunk and it passes. Equally, it works on my locally compiled 32bit build.

Comment 3

a year ago
Also works on this Tinderbox build:
https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=a09ebe0269abee8765beb01e997ecfa6dff01372

Now I got it: It has to do with bug 1362461. There were a few days where the test failed.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(alice0775)
Flags: needinfo?(acelists)
Resolution: --- → DUPLICATE
Duplicate of bug: 1362461
You need to log in before you can comment on or make changes to this bug.