Closed Bug 1365505 Opened 2 years ago Closed 2 years ago

[Fennec][HLS] Turn on HLS native support not only for Nightly

Categories

(Firefox for Android :: Audio/Video, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 59
Tracking Status
relnote-firefox --- 59+
firefox56 --- wontfix
firefox57 --- wontfix
firefox59 --- fixed

People

(Reporter: JamesCheng, Assigned: kikuo)

References

(Depends on 3 open bugs)

Details

Attachments

(2 files, 2 obsolete files)

We intend to enable HLS support only for nightly.

Three parts need to take care(should remove the '''nightly only''' flag in the future)
1.
Bug 1341990 - Part 0: Add a feature flag to control source code build time coverage for ExoPlayer.
2.
Bug 1350246 - [Part7] Define MOZ_ANDROID_HLS_SUPPORT macro and add the native code into source tree.
3.
Bug 1350246 - [Part4] Add a feature preference for HLS, default on for Fennec.
Summary: Turn on HLS native support not only for Nightly → [Fennec][HLS] Turn on HLS native support not only for Nightly
Depends on: 1373500
AppConstants.NIGHTLY_BUILD || AppConstants.DEBUG_BUILD should remove AppConstants.NIGHTLY_BUILD when we support HLS not only on Nightly build.
According to the SV's pre-beta sign-off report.

I think we could let this feature ride on FX 56, is that ok ?
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(bwu)
Flags: needinfo?(bchien)
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
To comment 2, Yes. Attached Pre-Beta Sign-off.

[Fennec] Make Gecko native support HLS on Fennec
Feature sign off report, Manual QA
Targeted GA: Firefox 56 - September 26, 2017
Sign off phase: Pre-Beta (Fx56).

Manual QA'S ASSESSMENT & RECOMMENDATION
Feature status:GREEN

    Reason: There are no blocking issues nor crashes, but there are still some bugs open .

    Proposed course of action: let this feature ride FX56 and fix open bugs during the beta cycle. 


MANUAL TESTING SUMMARY
Testing status: COMPLETED (100%)
  20 passed (83%), 0 blocked (0%), 4 failed with known bugs (17%), 0 failed with new bugs (0%)

    Test report: on TestRail
    New bugs uncovered during sign off: None
    Known bugs encountered during sign off:
         1377873, 1377891
Flags: needinfo?(bchien)
Assignee: nobody → jacheng
(In reply to Kilik Kuo [:kikuo] from comment #2)
> According to the SV's pre-beta sign-off report.
> 
> I think we could let this feature ride on FX 56, is that ok ?
Good job! Let's ship it!
Please create a patch to turn on it.
Flags: needinfo?(bwu)
Please see the patch for turning on this feature.
Comment on attachment 8892381 [details]
Bug 1365505 - Part2-Turn on the pref for hls not only on nightly.

https://reviewboard.mozilla.org/r/163336/#review168716

Ship it!
Attachment #8892381 - Flags: review?(bwu) → review+
Comment on attachment 8892380 [details]
Bug 1365505 - Part1-Make the feature flag be exposed not only on nightly.

https://reviewboard.mozilla.org/r/163334/#review168758
Attachment #8892380 - Flags: review?(kikuo) → review+
hg error in cmd: hg push -r tip ssh://hg.mozilla.org/integration/autoland: pushing to ssh://hg.mozilla.org/integration/autoland
searching for changes
remote: repository is read only
remote: Repo closed per glandium's request; sheriff not around to mark it closed, so deploying the read-only hammer.
remote: refusing to add changesets
remote: prechangegroup.readonly hook failed
abort: push failed on remote
Pushed by jacheng@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d5210a2cb19a
Part1-Make the feature flag be exposed not only on nightly. r=kikuo
https://hg.mozilla.org/integration/autoland/rev/80491c51a8e7
Part2-Turn on the pref for hls not only on nightly. r=bwu
https://hg.mozilla.org/mozilla-central/rev/d5210a2cb19a
https://hg.mozilla.org/mozilla-central/rev/80491c51a8e7
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Comment on attachment 8892380 [details]
Bug 1365505 - Part1-Make the feature flag be exposed not only on nightly.

Approval Request Comment
[Feature/Bug causing the regression]:Feature bug 1345752 for HLS playback on Fennec
[User impact if declined]: Cannot play video using HLS
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: SV has already tested and signed off.
[List of other uplifts needed for the feature/fix]: Part2 https://reviewboard.mozilla.org/r/163336/diff/1#index_header
[Is the change risky?]: na
[Why is the change risky/not risky?]: has already been tested through Nightly. 
[String changes made/needed]: na
Attachment #8892380 - Flags: approval-mozilla-beta?
Can you help on comment 13?
Flags: needinfo?(lhenry)
Flags: needinfo?(lhenry)
Comment on attachment 8892380 [details]
Bug 1365505 - Part1-Make the feature flag be exposed not only on nightly.

Has QE signoff, let's uplift for 56 beta 1.
Attachment #8892380 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Comment on attachment 8892381 [details]
Bug 1365505 - Part2-Turn on the pref for hls not only on nightly.

[Triage Comment]
Attachment #8892381 - Flags: approval-mozilla-beta+
Status: REOPENED → ASSIGNED
Release Note Request (optional, but appreciated)
[Why is this notable]: It has been disabled in 56, so the release note should be removed from https://www.mozilla.org/en-US/firefox/android/56.0beta/releasenotes/.
[Affects Firefox for Android]: Yes, only Firefox for Android
relnote-firefox: --- → ?
No longer depends on: gradle-automation
James, I learned from Max that even there are some minor remaining work about Gradle, it's now ready for you to bring HLS back since Fennec 59. Please go ahead and you may consult Max shall you have any question about the setup w/ Gradle. Thanks.
Flags: needinfo?(jacheng)
Thanks, I replied in Bug 1389990 comment 29
Flags: needinfo?(jacheng)
Attachment #8892380 - Attachment is obsolete: true
Attachment #8892381 - Attachment is obsolete: true
Comment on attachment 8930872 [details]
Bug 1365505 - [P1][Fennec] Enable HLS support by default for all brandings.

https://reviewboard.mozilla.org/r/201972/#review207646
Attachment #8930872 - Flags: review?(jolin) → review+
Blocks: 1420030
Comment on attachment 8933242 [details]
Bug 1365505 - [P2][Fennec] Only include exoplayer & HLSDecoder related components when building --with-gradle.

https://reviewboard.mozilla.org/r/204180/#review209712

Per Bug 1389990 Comment 42, I disable hls when building fennec without gradle.
Comment on attachment 8933242 [details]
Bug 1365505 - [P2][Fennec] Only include exoplayer & HLSDecoder related components when building --with-gradle.

https://reviewboard.mozilla.org/r/204180/#review210034
Attachment #8933242 - Flags: review?(max) → review+
Assignee: jacheng → kikuo
Pushed by kikuo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9545b9df0c6d
[P1][Fennec] Enable HLS support by default for all brandings. r=jolin
https://hg.mozilla.org/integration/autoland/rev/ce2c43ec79ae
[P2][Fennec] Only include exoplayer & HLSDecoder related components when building --with-gradle. r=maliu
https://hg.mozilla.org/mozilla-central/rev/9545b9df0c6d
https://hg.mozilla.org/mozilla-central/rev/ce2c43ec79ae
Status: ASSIGNED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
This was in the 56 beta notes as "Improved support for HLS (HTTP Live Streaming) playback". 

For now, I will add the same note back in for 59.0b1. 
What do you think? Is there anything more specific that you'd like to be in the note?
Flags: needinfo?(wehuang)
Thanks for the reminder, Liz! Yes the support was re-enabled in 59 Nightly and got pre-beta sign-off on Dec. 20, so should be included in the 59 release note instead, and I think the existing description holds well. Once the release note is public for comment I'll also ping media team and PM to see if they would like to refine anything specific.

(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #31)
> This was in the 56 beta notes as "Improved support for HLS (HTTP Live
> Streaming) playback". 
> 
> For now, I will add the same note back in for 59.0b1. 
> What do you think? Is there anything more specific that you'd like to be in
> the note?
Flags: needinfo?(wehuang)
You need to log in before you can comment on or make changes to this bug.