table in div is jumping using CSS-overflow and a mouseover-js

RESOLVED WORKSFORME

Status

()

Core
Layout
P3
normal
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: seth, Assigned: Marc Attinasi)

Tracking

Trunk
Future
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent:  Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9+)
Gecko/20020409
BuildID:    20020409

In http://www.bierdatenbank.de/testDir/biertests_standard.htm
there's a div, which should NOT jump.
but (div style="overflow:auto;")(table)...(/table)(/div) begins jumping, when 
using a special dynamic tooltip-javascript (from www.dhtmlcentral.com). and 
moving the mouse over the navigation-menu-links

Reproducible: Always
Steps to Reproduce:
1. only mozilla (and netscape6.x)
2. http://www.bierdatenbank.de/testDir/biertests_standard.htm 
3. mouse mouse over the menu-links (left hand, bgcolor=black)

Actual Results:  the centered maintable began jumping (and a tooltip appeared)

Expected Results:  the centered maintable should not jump (there should just 
appear a tooltip)

the error needs:
- mozilla
- style="overflow:auto;" (using "hidden" there's no error!)
- the tooltip-javascript

in my opinion the css-overflow is responsible

Comment 1

16 years ago
i see no flicer in the URL here, nor in the testcase, using 2002040903 XP.
i see severe flicker in bug 136549 though - perhaps another bug.

Comment 2

16 years ago
forget comment 1 - i DO see flicer! Comment was intended for another bug.

Comment 3

16 years ago
may be related to bug 136549 (and, originally, bug 128133)

Jake
Status: UNCONFIRMED → NEW
Ever confirmed: true
jkeiser, does your overflow-and-scrolling-stuff patch fix this?

Updated

16 years ago
Priority: -- → P3
Target Milestone: --- → Future

Comment 5

16 years ago
Changing QA contact
QA Contact: petersen → moied

Comment 6

16 years ago
I see it still in Linux 2002041407, which landed after bug 119849.  It is
entirely possible that there is a similar problem here.  I fixed one instance of
the problem in that bug, but not all.  If anyone calls
nsBoxToBlockAdaptor::GetPrefSize(), for example, the unconstrained reflow will
happen again.
(Reporter)

Comment 7

16 years ago
maybe related to bug 96756, because position:relative; fixes the
flickering problem...
Is this still a problem?

Comment 9

15 years ago
If bug 136549 is related to this, then yes, it is still a problem.  See the most
recently posted minimized testcase in that bug.  There is a slight flicker at
the top of the screen early on when using the menus.  It doesn't persist, but it
shouldn't be there at all.

Jake
Bug 136549 is bug 136549.  What does that have to do with this bug?  Unless
you're saying this should be marked duplicate?

Comment 11

15 years ago
If you don't think that bug 136549 has anything to do with this bug (duplicate
or whatever), then ignore my comment.  I just thought it might be related.  If
the same problem is causing the issue in that bug as this and it is apparent
that the testcase in that bug still displays the problem, then this bug is still
an issue.  It was just a hunch.  I have not looked at the Mozilla code that
might be causing the issue as you probably have, so I defer to your wisdom.

Jake
Well, it's just a matter of:

1)  If the only testcase that demonstrates this bug is in bug 136549 then this is
    a duplicate.
2)  If the testcase in bug 136549 has nothing to do with this bug, then this is
    worksforme.

Randomly picking a resolution....
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 13

15 years ago
hi!

<<If the only testcase that demonstrates this bug is in bug 136549 then this is 
a duplicate.>>
# you can see a severe flickering on 
http://www.bierdatenbank.de/testDir/biertests_standard.htm, whether its related 
do bug 136549, or not...

cheers
seth
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 14

15 years ago
sorry,
i was unfortunately using an wrong (older) version of mozilla. in 1.3 there is 
no flickering on that example-page.
again: i'm very sorry for that mistake!

cheers
seth
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME

Comment 15

15 years ago
Boris, I just rechecked the testcase in bug 136549 with the latest Mozilla
Firebird and I see no flicker.  I resolved that as WFM.  Your random resolution
is probably correct here as well.  Mozilla is behaving quite nicely :-)

Jake
You need to log in before you can comment on or make changes to this bug.