[Shutdown Decoder] OGV video elements are not suspended.

RESOLVED INVALID

Status

()

Firefox for Android
Audio/Video
P3
normal
RESOLVED INVALID
5 months ago
5 months ago

People

(Reporter: BogdanS, Assigned: kaku)

Tracking

(Blocks: 1 bug)

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox55 affected)

Details

(Reporter)

Description

5 months ago
Device: 
 - Nexus 5 (Android 6.0.1);
 - Galaxy Note 4 (Android 5.1).
Build:
 - Nightly 55.0a1 (2017-05-17);


Steps to reproduce:
1. Open Firefox and go to: https://goo.gl/49FJnb;
2. After video starts playing, load any page in another tab;
3. Switch back to the video tab.

Expected result:
 When switching back the last video frame should be displayed.

Actual result:
 Video elements were not suspended.
(Reporter)

Updated

5 months ago
See Also: → bug 1365582
(Assignee)

Updated

5 months ago
Assignee: nobody → kaku
Status: NEW → ASSIGNED
Priority: -- → P3
(Assignee)

Comment 1

5 months ago
Bogdan,

I cannot reproduce this bug on my devices, I have tried Nexus 6 (Android 7), ASUS ZenPhone GO (Android 5.1), and Pixel (Android 7).

I think that the video, on your devices, might be suspended, but is hard to be observed, because the resolution of the video you provided is very samll, which means it's resuming time is very quick!

I made a demo page to show the suspend and resume information. When the Gecko suspends a video element, it sends out a "mozentervideosuspend" event, and when it resumes a video, it sends out a "mozexitvideosuspend" event. Here is the page, https://people-mozilla.org/~tkuo/test/test_showSuspendAndResume/test.html

The information is shown on the page and console; you should be able to see them if the video is indeed suspended/resumed. Could you please check it?
Flags: needinfo?(bogdan.surd)
(Reporter)

Comment 2

5 months ago
Hello,

 Yes it is suspended, the video elements resumed too quick for me to notice the suspension because of the low video quality. I've pushed a OGV file to the device and used a html file to open it with the required modification so that the "mozentervideosuspend" & "mozexitvideosuspendand" events are displayed in the console. There is no problem and the video elements do indeed suspend.

Closing this issue.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 months ago
Flags: needinfo?(bogdan.surd)
Resolution: --- → INVALID
(Assignee)

Comment 3

5 months ago
Thanks for confirming!
You need to log in before you can comment on or make changes to this bug.