Caching bug when gzip/deflate encoding is enabled

RESOLVED INVALID

Status

()

RESOLVED INVALID
a year ago
a year ago

People

(Reporter: kopetepanda, Unassigned)

Tracking

53 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [necko-backlog])

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170504105526

Steps to reproduce:

Open a page "http://server0/filelist.php" with default 'network.http.accept-encoding'
Make another request to "http://server0/filelist.php" but this time the response is expected to change.


Actual results:

The response did not change.


Expected results:

The response should have changed but old response seems to be cached by Firefox, tried on chrome and opera, worked fine. Even deleting everything including cache using CTRL-SHIFT-DEL on firefox does not resolve the issue.

Temporary fix: change 'network.http.accept-encoding' to a blank value.
Component: Untriaged → Networking: HTTP
Product: Firefox → Core
Please, provide either a link to a site where the bug can be reproduced, or provide a http log of that problem, see https://developer.mozilla.org/en-US/docs/Mozilla/Debugging/HTTP_logging

Set "Log Modules" as follows: timestamp,sync,nsHttp:5,nsSocketTransport:5,nsStreamPump:5,nsHostResolver:5,cache2:5
Flags: needinfo?(kopetepanda)
Whiteboard: [necko-backlog]
(Reporter)

Comment 2

a year ago
Unable to replicate, closing
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(kopetepanda)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.