Closed Bug 1365763 Opened 5 years ago Closed 5 years ago

Trigger spidermonkey builds in more cases

Categories

(Firefox Build System :: General, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(2 files)

Yesterday, bug 1365194 burned the tree well after landing because
a) the failing sm builds never happened on try
b) the failing sm builds didn't happen on autoland
c) the failing sm builds only happened after autoland was merged to mozilla-central, presumably because something that landed before bug 1365194 touched js/

Enough is enough.
Funnily enough, the builds that failed are not even tc builds... they're buildbot builds, so this patch wouldn't have changed the outcome for bug 1365194...
How do we make the same change for buildbot?
Flags: needinfo?(catlee)
nthomas helped figure this out on irc.
Flags: needinfo?(catlee)
Comment on attachment 8868764 [details]
Bug 1365763 - Make all spidermonkey tasks depend on more file changes.

https://reviewboard.mozilla.org/r/140364/#review143676

Sorry, I had this done in bug 1325936 but got stalled off trying to implement one of your review suggestions there (removing some of the dependencies) and never landed. That was dumb.

I'll mark this r+ and dupe my bug to this. Removing dependencies can happen later.
Attachment #8868764 - Flags: review?(sphink) → review+
Duplicate of this bug: 1325936
Keywords: leave-open
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/36a35446bb72
Make all spidermonkey tasks depend on more file changes. r=sfink
Comment on attachment 8868787 [details]
Bug 1365763 - Use the same list as TC to trigger SM builds.

https://reviewboard.mozilla.org/r/140376/#review143702

Seems fine to me.
Attachment #8868787 - Flags: review?(nthomas) → review+
Status: NEW → RESOLVED
Closed: 5 years ago
Keywords: leave-open
Resolution: --- → FIXED
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.