No content in Browser/Sidebar. Build is not usable. Port Bug 780562 to SeaMonkey

RESOLVED FIXED in seamonkey2.52

Status

SeaMonkey
General
--
critical
RESOLVED FIXED
a month ago
a month ago

People

(Reporter: Hartmut Figge, Assigned: frg)

Tracking

(Blocks: 1 bug)

Trunk
seamonkey2.52

SeaMonkey Tracking Flags

(seamonkey2.52 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

a month ago
The current build of SM-Trunk Linux x86_64 is unusable. No content in browser or sidebar. MailNews seems usable at a first glance, but sending a composed message is not possible.

At startup of SM into browser with the sidebar enabled these messages are displayed:

JavaScript error: chrome://navigator/content/navigator.js, line 746: ReferenceError: isElementVisible is not defined
JavaScript error:chrome://communicator/content/sidebar/sidebarOverlay.js, line 714: NS_ERROR_ILLEGAL_VALUE: Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIRDFService.GetDataSourceBlocking]
Trying to bisect this.  So far it seems like a Mozilla-central change we will probably have to work around.
hg bisect identified this patch:

The first bad revision is:
changeset:   358639:82edbfe72c47
user:        Mike Hommey <mh+mozilla@glandium.org>
date:        Fri Apr 14 20:48:53 2017 +0900
summary:     Bug 780562 - Remove support for the chrome "platform" flag. r=bsmedberg

I am trying re-doing today's nightly with this backed out just to be sure.
(Reporter)

Comment 3

a month ago
A SM-Trunk built with a backout of 82edbfe72c47 does not show the problem of this bug. But, there are other problems now. Crash when closing a tab. After restart the password manager would not work for Login into Bugzilla. First time, before the crash, it worked. Hm.

May be another bug, though. A lot of checkins since my last build.
(Assignee)

Comment 4

a month ago
Yes. Looked at it and Bug 780562 needs to be ported.
Summary: No content in Browser/Sidebar. Build is not usable → No content in Browser/Sidebar. Build is not usable. Port 780562 to SeaMonkey
(Assignee)

Updated

a month ago
Blocks: 1345770
(Assignee)

Comment 5

a month ago
The tab close crash is probably bug 1363036
(Reporter)

Comment 6

a month ago
Yes. I'm now using a SM with the proposed patch of bug 1363036 and the backout of 82edbfe72c47. So far it works well.
(Assignee)

Updated

a month ago
Assignee: nobody → frgrahl
Status: NEW → ASSIGNED
Summary: No content in Browser/Sidebar. Build is not usable. Port 780562 to SeaMonkey → No content in Browser/Sidebar. Build is not usable. Port Bug 780562 to SeaMonkey
(Assignee)

Comment 7

a month ago
Created attachment 8869436 [details] [diff] [review]
1365811-platformremove.patch

As in Gecko I see no navigator-platform and communicator-platform usage outside of locales so more or less a straight port.
Attachment #8869436 - Flags: review?(iann_bugzilla)
(Reporter)

Comment 8

a month ago
WFM.

The issue with the password manager not working for Bugzilla is back. Worked with my previous build, the one withe the patch and the backout, but even there no longer. Fails also in another profile. Have to investigate. Difficult, when the issue is only sometimes there. *g*

But for your patch, that works.
(Reporter)

Comment 9

a month ago
Forget about the password manager. I'm now quite sure, it's something in my standard profile. That one dates back to before an alpha of SM existed.

Sorry for the noise.
(Assignee)

Comment 10

a month ago
There is a problem with the prompting if you started SeaMonkey with another component aka mail or composer. Or if you close the last browser Window and only leave a mail window open. I just can't find the bug # now. You need to close all non browser windows then. Should work again afterwards.
(Reporter)

Comment 11

a month ago
Not so sure, if I should mention the reason for my password problem here. Has nothing to do with the bug. Hm. Oh, well. There was one line in my prefs.js which caused the trouble. After deleting it all was fine again.

user_pref("privacy.sanitize.sanitizeOnShutdown", true);
(In reply to Frank-Rainer Grahl from comment #7)
> Created attachment 8869436 [details] [diff] [review]
> 1365811-platformremove.patch
> 
> As in Gecko I see no navigator-platform and communicator-platform usage
> outside of locales so more or less a straight port.

I did today's builds using this patch rather than my lame back-out and this definitely fixes the issue.  Thanks so much for getting a fix so quickly.  I am also happy that I was able to help in a small way in identifying the underlying issue.

Comment 13

a month ago
Comment on attachment 8869436 [details] [diff] [review]
1365811-platformremove.patch

LGTM r=me
Attachment #8869436 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 14

a month ago
https://hg.mozilla.org/comm-central/rev/263a5803a9f20067474402a28144b6645e77848e
Status: ASSIGNED → RESOLVED
Last Resolved: a month ago
status-seamonkey2.52: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.52
You need to log in before you can comment on or make changes to this bug.