Closed Bug 1365839 Opened 2 years ago Closed 2 years ago

"Download and Install" button should show build ID on Nightly

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 55
Tracking Status
firefox55 --- fixed

People

(Reporter: timdream, Assigned: timdream)

Details

(Keywords: dupeme)

Attachments

(2 files)

To see this bug you would need to set the updater to "Check for updates but let you choose to install them", but the screenshot should illustrate this well. The current UI is essentially telling people to update from 55.0a1 to 55.0a1...?

To manually test this do:

1. Open chrome://browser/content/aboutDialog.xul or about:preferences#advanced
2. Open DevTools console
3. `Object.defineProperties(gAppUpdater, { "update": { value: { displayVersion: "55.0a1", "buildID": "20170517030204" } } }); gAppUpdater.selectPanel('downloadAndInstall');`
Comment on attachment 8868876 [details]
Bug 1365839 - Include build ID on the download and install button.

https://reviewboard.mozilla.org/r/140482/#review143808

::: browser/base/content/aboutDialog-appUpdater.js:180
(Diff revision 1)
>      if (button) {
>        if (aChildID == "downloadAndInstall") {
>          let updateVersion = gAppUpdater.update.displayVersion;
> +        // Include the build ID if this is an "a#" (nightly or aurora) build
> +        if (/a\d+$/.test(updateVersion)) {
> +          let buildID = gAppUpdater.update.buildID;

These are simply copied from

http://searchfox.org/mozilla-central/rev/f55349994fdac101d121b11dac769f3f17fbec4b/browser/base/content/aboutDialog.js#37-41
Please look for dupes when this lands, I'm pretty sure we have some on file...
Comment on attachment 8868876 [details]
Bug 1365839 - Include build ID on the download and install button.

https://reviewboard.mozilla.org/r/140482/#review144492

LGTM! Thanks for keeping at this and making it better ;)
Attachment #8868876 - Flags: review?(mdeboer) → review+
My Bugzilla search fu only gave me bug 675192. I couldn't find any exact dup.
Pushed by mdeboer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a3c06eb37887
Include build ID on the download and install button. r=mikedeboer
(In reply to Tim Guan-tin Chien [:timdream] (please needinfo) from comment #5)
> My Bugzilla search fu only gave me bug 675192. I couldn't find any exact dup.

Also bug 737215, but you're right - you're adding this in a much more specific location, and not for the about window generally...
https://hg.mozilla.org/mozilla-central/rev/a3c06eb37887
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
I have reproduced this bug with Nightly 55.0a1 (2017-05-17) on Windows 8.1 , 64 Bit ! 

This bug's fix is Verified with latest Nightly 55.0a1 !

Build   ID    20170524030204
User Agent    Mozilla/5.0 (Windows NT 6.3; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0

[bugday-20170524]
QA Whiteboard: [bugday-20170524]
I have reproduced this bug with Nightly 55.0a1 (2017-05-17) (64-bit) on Ubuntu 16.04 64 Bit LTS! 

This bug's fix is Verified with latest Nightly!

Build   ID    20170523100217
User Agent    Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0

[bugday-20170524]
You need to log in before you can comment on or make changes to this bug.