Closed Bug 1365850 Opened 3 years ago Closed 2 years ago

Intermittent browser/base/content/test/webrtc/browser_devices_get_user_media_queue_request.js | received error: NotReadableError: Failed to allocate videosource - Got ok, expected error: NotReadableError: Failed to allocate videosource

Categories

(Core :: WebRTC: Audio/Video, defect, P3)

Unspecified
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 861716
Blocking Flags:
backlog tech-debt

People

(Reporter: mchiang, Unassigned)

Details

No description provided.
OS: Unspecified → Linux
It is unclear how common this is.
backlog: --- → tech-debt
Rank: 35
Priority: -- → P3
https://treeherder.mozilla.org/#/jobs?repo=try&revision=7c8c52fcc12cb1b37ffefee78b5226b051f221b3

Somehow on Linux try machine, gUM({ video: { deviceId: 'bad device' }, fake: true }) failed to provoke NotReadable error.
This issue doesn't occur on my local Linux machine.

Still figuring out.
On the Linux try machine, gUM({ video: { deviceId: 'bad device' }, fake: true }) doesn't create a fake backend.
Only fake backend would provoke a NotReadable error when the constraint contains the keyword 'bad device'
This bug has been addressed in bug 861716.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 861716
You need to log in before you can comment on or make changes to this bug.